Merge commit mesa-public/master into vulkan
[mesa.git] / src / compiler / glsl / Makefile.am
index 9954b81240338659ec881300cf3eec29dcc067c4..d6b1f9ed6958da6d852e88aba95229352c7b0390 100644 (file)
@@ -66,7 +66,7 @@ check_PROGRAMS =                                      \
        tests/sampler-types-test                        \
        tests/uniform-initializer-test
 
-noinst_PROGRAMS = glsl_compiler
+noinst_PROGRAMS = glsl_compiler spirv2nir
 
 tests_blob_test_SOURCES =                              \
        tests/blob_test.c
@@ -135,7 +135,6 @@ libglsl_la_SOURCES =                                        \
        glsl_parser.h                                   \
        $(LIBGLSL_FILES)
 
-
 glsl_compiler_SOURCES = \
        $(GLSL_COMPILER_CXX_FILES)
 
@@ -145,6 +144,16 @@ glsl_compiler_LDADD =                                      \
        $(top_builddir)/src/util/libmesautil.la         \
        $(PTHREAD_LIBS)
 
+spirv2nir_SOURCES = \
+       standalone_scaffolding.cpp \
+       standalone_scaffolding.h \
+       nir/spirv2nir.c
+
+spirv2nir_LDADD =                                      \
+       libglsl.la                                      \
+       $(top_builddir)/src/libglsl_util.la             \
+       $(PTHREAD_LIBS)
+
 glsl_test_SOURCES = \
        standalone_scaffolding.cpp \
        test.cpp \