nir: Report progress properly in nir_lower_bool_to_*
[mesa.git] / src / compiler / nir / meson.build
index d4203e34ac931a2a0c3129ad9d852aaf83184b3e..71fed704af64cfbff695a4139c27046111f5bdc0 100644 (file)
@@ -138,6 +138,7 @@ files_libnir = files(
   'nir_lower_fragcolor.c',
   'nir_lower_frexp.c',
   'nir_lower_global_vars_to_local.c',
+  'nir_lower_goto_ifs.c',
   'nir_lower_gs_intrinsics.c',
   'nir_lower_load_const_to_scalar.c',
   'nir_lower_locals_to_regs.c',
@@ -153,6 +154,7 @@ files_libnir = files(
   'nir_lower_io_to_scalar.c',
   'nir_lower_io_to_vector.c',
   'nir_lower_mediump_outputs.c',
+  'nir_lower_memory_model.c',
   'nir_lower_non_uniform_access.c',
   'nir_lower_packing.c',
   'nir_lower_passthrough_edgeflags.c',
@@ -178,6 +180,7 @@ files_libnir = files(
   'nir_lower_wpos_ytransform.c',
   'nir_lower_wrmasks.c',
   'nir_lower_bit_size.c',
+  'nir_lower_ubo_vec4.c',
   'nir_lower_uniforms_to_ubo.c',
   'nir_metadata.c',
   'nir_move_vec_src_uses_to_dest.c',
@@ -206,7 +209,7 @@ files_libnir = files(
   'nir_opt_peephole_select.c',
   'nir_opt_rematerialize_compares.c',
   'nir_opt_remove_phis.c',
-  'nir_opt_shrink_load.c',
+  'nir_opt_shrink_vectors.c',
   'nir_opt_sink.c',
   'nir_opt_trivial_continues.c',
   'nir_opt_undef.c',
@@ -220,6 +223,7 @@ files_libnir = files(
   'nir_remove_dead_variables.c',
   'nir_repair_ssa.c',
   'nir_schedule.c',
+  'nir_schedule.h',
   'nir_search.c',
   'nir_search.h',
   'nir_search_helpers.h',
@@ -381,4 +385,17 @@ if with_tests
     ),
     suite : ['compiler', 'nir'],
   )
+
+  test(
+    'nir_opt_if',
+    executable(
+      'nir_opt_if_tests',
+      files('tests/opt_if_tests.cpp'),
+      cpp_args : [cpp_msvc_compat_args],
+      gnu_symbol_visibility : 'hidden',
+      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
+      dependencies : [dep_thread, idep_gtest, idep_nir, idep_mesautil],
+    ),
+    suite : ['compiler', 'nir'],
+  )
 endif