nir: Remove the old nir_opt_shrink_load.
[mesa.git] / src / compiler / nir / meson.build
index 15d73b5aede7a63c454fbd3fbc6ecd2f91c9419d..f74a591926aabc70910c12b200f11e9323bc2719 100644 (file)
@@ -125,6 +125,7 @@ files_libnir = files(
   'nir_lower_clamp_color_outputs.c',
   'nir_lower_clip.c',
   'nir_lower_clip_cull_distance_arrays.c',
+  'nir_lower_clip_disable.c',
   'nir_lower_clip_halfz.c',
   'nir_lower_variable_initializers.c',
   'nir_lower_discard_to_demote.c',
@@ -134,6 +135,7 @@ files_libnir = files(
   'nir_lower_flatshade.c',
   'nir_lower_flrp.c',
   'nir_lower_fragcoord_wtrans.c',
+  'nir_lower_fragcolor.c',
   'nir_lower_frexp.c',
   'nir_lower_global_vars_to_local.c',
   'nir_lower_gs_intrinsics.c',
@@ -151,6 +153,7 @@ files_libnir = files(
   'nir_lower_io_to_scalar.c',
   'nir_lower_io_to_vector.c',
   'nir_lower_mediump_outputs.c',
+  'nir_lower_memory_model.c',
   'nir_lower_non_uniform_access.c',
   'nir_lower_packing.c',
   'nir_lower_passthrough_edgeflags.c',
@@ -204,7 +207,7 @@ files_libnir = files(
   'nir_opt_peephole_select.c',
   'nir_opt_rematerialize_compares.c',
   'nir_opt_remove_phis.c',
-  'nir_opt_shrink_load.c',
+  'nir_opt_shrink_vectors.c',
   'nir_opt_sink.c',
   'nir_opt_trivial_continues.c',
   'nir_opt_undef.c',
@@ -218,6 +221,7 @@ files_libnir = files(
   'nir_remove_dead_variables.c',
   'nir_repair_ssa.c',
   'nir_schedule.c',
+  'nir_schedule.h',
   'nir_search.c',
   'nir_search.h',
   'nir_search_helpers.h',
@@ -258,7 +262,8 @@ _libnir = static_library(
    nir_opcodes_h, nir_constant_expressions_c, nir_builder_opcodes_h,
    vtn_gather_types_c, nir_intrinsics_c, nir_intrinsics_h],
   include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux, inc_compiler, include_directories('../spirv')],
-  c_args : [c_vis_args, c_msvc_compat_args, no_override_init_args],
+  c_args : [c_msvc_compat_args, no_override_init_args],
+  gnu_symbol_visibility : 'hidden',
   link_with : libcompiler,
   build_by_default : false,
 )
@@ -283,7 +288,8 @@ if with_tests
     executable(
       'nir_builder_test',
       files('tests/builder_tests.cpp'),
-      cpp_args : [cpp_vis_args, cpp_msvc_compat_args],
+      cpp_args : [cpp_msvc_compat_args],
+      gnu_symbol_visibility : 'hidden',
       include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
       dependencies : [dep_thread, idep_gtest, idep_nir, idep_mesautil],
     ),
@@ -295,7 +301,8 @@ if with_tests
     executable(
       'nir_control_flow_test',
       files('tests/control_flow_tests.cpp'),
-      cpp_args : [cpp_vis_args, cpp_msvc_compat_args],
+      cpp_args : [cpp_msvc_compat_args],
+      gnu_symbol_visibility : 'hidden',
       include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
       dependencies : [dep_thread, idep_gtest, idep_nir, idep_mesautil],
     ),
@@ -307,7 +314,8 @@ if with_tests
     executable(
       'nir_vars_test',
       files('tests/vars_tests.cpp'),
-      cpp_args : [cpp_vis_args, cpp_msvc_compat_args],
+      cpp_args : [cpp_msvc_compat_args],
+      gnu_symbol_visibility : 'hidden',
       include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
       dependencies : [dep_thread, idep_gtest, idep_nir, idep_mesautil],
     ),
@@ -328,7 +336,8 @@ if with_tests
     executable(
       'negative_equal',
       files('tests/negative_equal_tests.cpp'),
-      c_args : [c_vis_args, c_msvc_compat_args, no_override_init_args],
+      c_args : [c_msvc_compat_args, no_override_init_args],
+      gnu_symbol_visibility : 'hidden',
       include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
       dependencies : [dep_thread, idep_gtest, idep_nir, idep_mesautil],
     ),
@@ -340,7 +349,8 @@ if with_tests
     executable(
       'comparison_pre',
       files('tests/comparison_pre_tests.cpp'),
-      c_args : [c_vis_args, c_msvc_compat_args, no_override_init_args],
+      c_args : [c_msvc_compat_args, no_override_init_args],
+      gnu_symbol_visibility : 'hidden',
       include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
       dependencies : [dep_thread, idep_gtest, idep_nir, idep_mesautil],
     ),
@@ -352,7 +362,8 @@ if with_tests
     executable(
       'load_store_vectorizer',
       files('tests/load_store_vectorizer_tests.cpp'),
-      cpp_args : [cpp_vis_args, cpp_msvc_compat_args],
+      cpp_args : [cpp_msvc_compat_args],
+      gnu_symbol_visibility : 'hidden',
       include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
       dependencies : [dep_thread, idep_gtest, idep_nir, idep_mesautil],
     ),
@@ -365,7 +376,21 @@ if with_tests
     executable(
       'nir_serialize_test',
       files('tests/serialize_tests.cpp'),
-      cpp_args : [cpp_vis_args, cpp_msvc_compat_args],
+      cpp_args : [cpp_msvc_compat_args],
+      gnu_symbol_visibility : 'hidden',
+      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
+      dependencies : [dep_thread, idep_gtest, idep_nir, idep_mesautil],
+    ),
+    suite : ['compiler', 'nir'],
+  )
+
+  test(
+    'nir_opt_if',
+    executable(
+      'nir_opt_if_tests',
+      files('tests/opt_if_tests.cpp'),
+      cpp_args : [cpp_msvc_compat_args],
+      gnu_symbol_visibility : 'hidden',
       include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
       dependencies : [dep_thread, idep_gtest, idep_nir, idep_mesautil],
     ),