nir/scheduler: Move nir_scheduler to its own header
[mesa.git] / src / compiler / nir / meson.build
index 43a91769253b653f36aa2336ba786dca045ba74a..faa141c7f9598013004de6b37103b4e5c806933d 100644 (file)
@@ -94,6 +94,7 @@ files_libnir = files(
   'nir_control_flow.c',
   'nir_control_flow.h',
   'nir_control_flow_private.h',
+  'nir_convert_ycbcr.c',
   'nir_deref.c',
   'nir_deref.h',
   'nir_divergence_analysis.c',
@@ -118,18 +119,23 @@ files_libnir = files(
   'nir_lower_array_deref_of_vec.c',
   'nir_lower_atomics_to_ssbo.c',
   'nir_lower_bitmap.c',
+  'nir_lower_bool_to_bitsize.c',
   'nir_lower_bool_to_float.c',
   'nir_lower_bool_to_int32.c',
   'nir_lower_clamp_color_outputs.c',
   'nir_lower_clip.c',
   'nir_lower_clip_cull_distance_arrays.c',
-  'nir_lower_constant_initializers.c',
+  'nir_lower_clip_disable.c',
+  'nir_lower_clip_halfz.c',
+  'nir_lower_variable_initializers.c',
+  'nir_lower_discard_to_demote.c',
   'nir_lower_double_ops.c',
   'nir_lower_drawpixels.c',
   'nir_lower_fb_read.c',
   'nir_lower_flatshade.c',
   'nir_lower_flrp.c',
   'nir_lower_fragcoord_wtrans.c',
+  'nir_lower_fragcolor.c',
   'nir_lower_frexp.c',
   'nir_lower_global_vars_to_local.c',
   'nir_lower_gs_intrinsics.c',
@@ -146,6 +152,7 @@ files_libnir = files(
   'nir_lower_io_to_temporaries.c',
   'nir_lower_io_to_scalar.c',
   'nir_lower_io_to_vector.c',
+  'nir_lower_mediump_outputs.c',
   'nir_lower_non_uniform_access.c',
   'nir_lower_packing.c',
   'nir_lower_passthrough_edgeflags.c',
@@ -157,6 +164,7 @@ files_libnir = files(
   'nir_lower_returns.c',
   'nir_lower_samplers.c',
   'nir_lower_scratch.c',
+  'nir_lower_ssbo.c',
   'nir_lower_subgroups.c',
   'nir_lower_system_values.c',
   'nir_lower_tex.c',
@@ -168,12 +176,14 @@ files_libnir = files(
   'nir_lower_viewport_transform.c',
   'nir_lower_wpos_center.c',
   'nir_lower_wpos_ytransform.c',
+  'nir_lower_wrmasks.c',
   'nir_lower_bit_size.c',
   'nir_lower_uniforms_to_ubo.c',
   'nir_metadata.c',
   'nir_move_vec_src_uses_to_dest.c',
   'nir_normalize_cubemap_coords.c',
   'nir_opt_access.c',
+  'nir_opt_barriers.c',
   'nir_opt_combine_stores.c',
   'nir_opt_comparison_pre.c',
   'nir_opt_conditional_discard.c',
@@ -210,6 +220,7 @@ files_libnir = files(
   'nir_remove_dead_variables.c',
   'nir_repair_ssa.c',
   'nir_schedule.c',
+  'nir_schedule.h',
   'nir_search.c',
   'nir_search.h',
   'nir_search_helpers.h',
@@ -222,6 +233,7 @@ files_libnir = files(
   'nir_to_lcssa.c',
   'nir_validate.c',
   'nir_vla.h',
+  'nir_vulkan.h',
   'nir_worklist.c',
   'nir_worklist.h',
   'nir_xfb_info.h',
@@ -248,8 +260,9 @@ _libnir = static_library(
   [files_libnir, spirv_info_c, nir_opt_algebraic_c, nir_opcodes_c,
    nir_opcodes_h, nir_constant_expressions_c, nir_builder_opcodes_h,
    vtn_gather_types_c, nir_intrinsics_c, nir_intrinsics_h],
-  include_directories : [inc_common, inc_compiler, include_directories('../spirv')],
-  c_args : [c_vis_args, c_msvc_compat_args, no_override_init_args],
+  include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux, inc_compiler, include_directories('../spirv')],
+  c_args : [c_msvc_compat_args, no_override_init_args],
+  gnu_symbol_visibility : 'hidden',
   link_with : libcompiler,
   build_by_default : false,
 )
@@ -274,8 +287,9 @@ if with_tests
     executable(
       'nir_builder_test',
       files('tests/builder_tests.cpp'),
-      cpp_args : [cpp_vis_args, cpp_msvc_compat_args],
-      include_directories : [inc_common],
+      cpp_args : [cpp_msvc_compat_args],
+      gnu_symbol_visibility : 'hidden',
+      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
       dependencies : [dep_thread, idep_gtest, idep_nir, idep_mesautil],
     ),
     suite : ['compiler', 'nir'],
@@ -286,8 +300,9 @@ if with_tests
     executable(
       'nir_control_flow_test',
       files('tests/control_flow_tests.cpp'),
-      cpp_args : [cpp_vis_args, cpp_msvc_compat_args],
-      include_directories : [inc_common],
+      cpp_args : [cpp_msvc_compat_args],
+      gnu_symbol_visibility : 'hidden',
+      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
       dependencies : [dep_thread, idep_gtest, idep_nir, idep_mesautil],
     ),
     suite : ['compiler', 'nir'],
@@ -298,8 +313,9 @@ if with_tests
     executable(
       'nir_vars_test',
       files('tests/vars_tests.cpp'),
-      cpp_args : [cpp_vis_args, cpp_msvc_compat_args],
-      include_directories : [inc_common],
+      cpp_args : [cpp_msvc_compat_args],
+      gnu_symbol_visibility : 'hidden',
+      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
       dependencies : [dep_thread, idep_gtest, idep_nir, idep_mesautil],
     ),
     suite : ['compiler', 'nir'],
@@ -319,8 +335,9 @@ if with_tests
     executable(
       'negative_equal',
       files('tests/negative_equal_tests.cpp'),
-      c_args : [c_vis_args, c_msvc_compat_args, no_override_init_args],
-      include_directories : [inc_common],
+      c_args : [c_msvc_compat_args, no_override_init_args],
+      gnu_symbol_visibility : 'hidden',
+      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
       dependencies : [dep_thread, idep_gtest, idep_nir, idep_mesautil],
     ),
     suite : ['compiler', 'nir'],
@@ -331,8 +348,9 @@ if with_tests
     executable(
       'comparison_pre',
       files('tests/comparison_pre_tests.cpp'),
-      c_args : [c_vis_args, c_msvc_compat_args, no_override_init_args],
-      include_directories : [inc_common],
+      c_args : [c_msvc_compat_args, no_override_init_args],
+      gnu_symbol_visibility : 'hidden',
+      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
       dependencies : [dep_thread, idep_gtest, idep_nir, idep_mesautil],
     ),
     suite : ['compiler', 'nir'],
@@ -343,11 +361,13 @@ if with_tests
     executable(
       'load_store_vectorizer',
       files('tests/load_store_vectorizer_tests.cpp'),
-      cpp_args : [cpp_vis_args, cpp_msvc_compat_args],
-      include_directories : [inc_common],
+      cpp_args : [cpp_msvc_compat_args],
+      gnu_symbol_visibility : 'hidden',
+      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
       dependencies : [dep_thread, idep_gtest, idep_nir, idep_mesautil],
     ),
     suite : ['compiler', 'nir'],
+    should_fail : meson.get_cross_property('xfail', '').contains('load_store_vectorizer'),
   )
 
   test(
@@ -355,8 +375,22 @@ if with_tests
     executable(
       'nir_serialize_test',
       files('tests/serialize_tests.cpp'),
-      cpp_args : [cpp_vis_args, cpp_msvc_compat_args],
-      include_directories : [inc_common],
+      cpp_args : [cpp_msvc_compat_args],
+      gnu_symbol_visibility : 'hidden',
+      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
+      dependencies : [dep_thread, idep_gtest, idep_nir, idep_mesautil],
+    ),
+    suite : ['compiler', 'nir'],
+  )
+
+  test(
+    'nir_opt_if',
+    executable(
+      'nir_opt_if_tests',
+      files('tests/opt_if_tests.cpp'),
+      cpp_args : [cpp_msvc_compat_args],
+      gnu_symbol_visibility : 'hidden',
+      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
       dependencies : [dep_thread, idep_gtest, idep_nir, idep_mesautil],
     ),
     suite : ['compiler', 'nir'],