drm-shim: Let the driver choose to overwrite the first render node.
[mesa.git] / src / drm-shim / meson.build
index 1638c5ae728e8f2334364121401e76d86168b62e..197c8253995acdce4c3ac38f77620965aa3a3541 100644 (file)
@@ -24,11 +24,11 @@ drm_shim = static_library(
     'device.c',
     'drm_shim.c',
   ],
-  link_with: libmesa_util,
-  include_directories: [inc_common],
-  dependencies: [dep_dl],
+  include_directories: [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
+  dependencies: [dep_libdrm, idep_mesautil, dep_dl],
   c_args : [c_vis_args, '-std=gnu99'],
 )
 dep_drm_shim = declare_dependency(
-  link_with: drm_shim
+  link_with: drm_shim,
+  dependencies: dep_libdrm,
 )