Added few more stubs so that control reaches to DestroyDevice().
[mesa.git] / src / drm-shim / meson.build
index 197c8253995acdce4c3ac38f77620965aa3a3541..2a7ea000a61750138d36b672aaf0bd283ec219af 100644 (file)
@@ -1,4 +1,5 @@
 # Copyright © 2019 Broadcom
+# Copyright © 2020 Intel Corporation
 #
 # Permission is hereby granted, free of charge, to any person obtaining a copy
 # of this software and associated documentation files (the "Software"), to deal
 # SOFTWARE.
 
 drm_shim = static_library(
-  ['drm_shim'],
+  'drm_shim',
   [
     'device.c',
     'drm_shim.c',
   ],
   include_directories: [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
   dependencies: [dep_libdrm, idep_mesautil, dep_dl],
-  c_args : [c_vis_args, '-std=gnu99'],
+  gnu_symbol_visibility : 'hidden',
+  override_options : ['c_std=gnu99'],
 )
 dep_drm_shim = declare_dependency(
   link_with: drm_shim,