drm-shim/meson: The name of the target is a string not a list
[mesa.git] / src / drm-shim / meson.build
index c22aea87349d9adad752cb7d9976021d53a6c307..39d739610ab70226b449e77174187af243993fd3 100644 (file)
@@ -1,4 +1,5 @@
 # Copyright © 2019 Broadcom
+# Copyright © 2020 Intel Corporation
 #
 # Permission is hereby granted, free of charge, to any person obtaining a copy
 # of this software and associated documentation files (the "Software"), to deal
 # SOFTWARE.
 
 drm_shim = static_library(
-  ['drm_shim'],
+  'drm_shim',
   [
     'device.c',
     'drm_shim.c',
   ],
   include_directories: [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
-  dependencies: [idep_mesautil, dep_dl],
+  dependencies: [dep_libdrm, idep_mesautil, dep_dl],
   c_args : [c_vis_args, '-std=gnu99'],
 )
 dep_drm_shim = declare_dependency(
-  link_with: drm_shim
+  link_with: drm_shim,
+  dependencies: dep_libdrm,
 )