mapi: move genCommon.py to src/mapi/new
[mesa.git] / src / egl / Makefile.am
index ff928525e6ce257c3a7511819089cfe56be11e4d..de4a754a2dbde1628daff059f431aed3dc871d17 100644 (file)
@@ -136,10 +136,18 @@ libEGL_common_la_LIBADD += \
        $(LIBDRM_LIBS) \
        $(CLOCK_LIB)
 
-GLVND_GEN_DEPS = generate/gen_egl_dispatch.py \
-       generate/egl.xml generate/eglFunctionList.py generate/genCommon.py \
+# dummy rule to keep dist happy
+$(top_scrdir)/src/mapi/new/genCommon.py:
+
+GLVND_GEN_EGL_DEPS = \
+       generate/gen_egl_dispatch.py \
+       generate/eglFunctionList.py \
+       generate/egl.xml \
        generate/egl_other.xml
 
+GLVND_GEN_DEPS = $(top_scrdir)/src/mapi/new/genCommon.py \
+       $(GLVND_GEN_EGL_DEPS)
+
 PYTHON_GEN = $(AM_V_GEN)$(PYTHON) $(PYTHON_FLAGS)
 g_egldispatchstubs.c: $(GLVND_GEN_DEPS)
        $(PYTHON_GEN) $(top_srcdir)/src/egl/generate/gen_egl_dispatch.py source \
@@ -226,6 +234,6 @@ EXTRA_DIST = \
        drivers/haiku \
        main/egl.def \
        main/README.txt \
-       $(GLVND_GEN_DEPS) \
+       $(GLVND_GEN_EGL_DEPS) \
        main/50_mesa.json \
        meson.build