meson: revert glvnd workaround
[mesa.git] / src / egl / meson.build
index 9c2c055c3eb07f8852345e0bf3e58d61920492de..14aca2a2186ea62bd21b7756f00ea9b80f93a491 100644 (file)
@@ -173,21 +173,12 @@ libegl = shared_library(
   version : egl_lib_version,
 )
 
-# If using glvnd the pkg-config header should not point to EGL_mesa, it should
-# point to EGL. glvnd is only available on unix like platforms so adding -l
-# should be safe here
-if not with_glvnd or not glvnd_has_headers_and_pc_files
-  if not glvnd_has_headers_and_pc_files
-    _egl = '-L${libdir} -lEGL'
-  else
-    _egl = libegl
-  endif
-
+if not with_glvnd
   pkg.generate(
     name : 'egl',
     description : 'Mesa EGL Library',
     version : meson.project_version(),
-    libraries : _egl,
+    libraries : libegl,
     libraries_private: gl_priv_libs,
     requires_private : gl_priv_reqs,
     extra_cflags : gl_pkgconfig_c_flags,