egl: put full path to libEGL_mesa.so in GLVND json
[mesa.git] / src / egl / meson.build
index 12d74ec37faacbb4c53e4ddcb9c0d21d28bd4551..db34453ee9b21c9c772f27326f753e29e1876040 100644 (file)
@@ -152,8 +152,18 @@ else
   deps_for_egl += dep_glvnd
   files_egl += [g_egldispatchstubs_h, g_egldispatchstubs_c]
   files_egl += files('main/eglglvnd.c', 'main/egldispatchstubs.c')
-  install_data(
-    'main/50_mesa.json',
+
+  egl_icd = custom_target(
+    'glvnd_icd',
+    input : 'glvnd_icd.py',
+    output : '50_mesa.json',
+    command : [
+      prog_python, '@INPUT@',
+      '--lib-path', join_paths(get_option('prefix'), get_option('libdir')),
+      '--out', '@OUTPUT@',
+    ],
+    build_by_default : true,
+    install : true,
     install_dir : join_paths(get_option('datadir'), 'glvnd', 'egl_vendor.d')
   )
 endif