egl: rewrite entrypoints check
[mesa.git] / src / egl / meson.build
index 6537e4bdee61a49e5ae855c18584d472567553ee..019f79ee212badd0c05f4630e978babb3d34c741 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright © 2017 Intel Corporation
+# Copyright Â© 2017 Intel Corporation
 
 # Permission is hereby granted, free of charge, to any person obtaining a copy
 # of this software and associated documentation files (the "Software"), to deal
@@ -38,11 +38,12 @@ files_egl = files(
   'main/eglcurrent.c',
   'main/eglcurrent.h',
   'main/egldefines.h',
+  'main/egldevice.c',
+  'main/egldevice.h',
   'main/egldisplay.c',
   'main/egldisplay.h',
   'main/egldriver.c',
   'main/egldriver.h',
-  'main/eglfallbacks.c',
   'main/eglglobals.c',
   'main/eglglobals.h',
   'main/eglimage.c',
@@ -60,28 +61,28 @@ files_egl = files(
 g_egldispatchstubs_c = custom_target(
   'g_egldispatchstubs.c',
   input : [
-    'generate/gen_egl_dispatch.py', 'generate/eglFunctionList.py',
+    'generate/gen_egl_dispatch.py',
     'generate/egl.xml', 'generate/egl_other.xml'
   ],
   output : 'g_egldispatchstubs.c',
   command : [
-    prog_python2, '@INPUT0@', 'source', '@INPUT1@', '@INPUT2@', '@INPUT3@'
+    prog_python, '@INPUT0@', 'source', '@INPUT1@', '@INPUT2@',
   ],
-  depend_files : files('generate/genCommon.py'),
+  depend_files : [ files('generate/eglFunctionList.py'), genCommon_py, ],
   capture : true,
 )
 
 g_egldispatchstubs_h = custom_target(
   'g_egldispatchstubs.h',
   input : [
-    'generate/gen_egl_dispatch.py', 'generate/eglFunctionList.py',
+    'generate/gen_egl_dispatch.py',
     'generate/egl.xml', 'generate/egl_other.xml'
   ],
   output : 'g_egldispatchstubs.h',
   command : [
-    prog_python2, '@INPUT0@', 'header', '@INPUT1@', '@INPUT2@', '@INPUT3@'
+    prog_python, '@INPUT0@', 'header', '@INPUT1@', '@INPUT2@',
   ],
-  depend_files : files('generate/genCommon.py'),
+  depend_files : [ files('generate/eglFunctionList.py'), genCommon_py, ],
   capture : true,
 )
 
@@ -91,47 +92,43 @@ if with_dri2
     'drivers/dri2/egl_dri2.h',
     'drivers/dri2/egl_dri2_fallbacks.h',
   )
-  c_args_for_egl += [
-    '-DDEFAULT_DRIVER_DIR="@0@"'.format(dri_search_path),
-    '-D_EGL_BUILT_IN_DRIVER_DRI2',
-  ]
-endif
-
-if with_platform_x11
-  files_egl += files('drivers/dri2/platform_x11.c')
-  if with_dri3
-    files_egl += files('drivers/dri2/platform_x11_dri3.c')
-    link_for_egl += libloader_dri3_helper
+  link_for_egl += [libloader, libxmlconfig]
+  incs_for_egl += inc_loader
+
+  files_egl += files('drivers/dri2/platform_device.c')
+  if with_platform_x11
+    files_egl += files('drivers/dri2/platform_x11.c')
+    if with_dri3
+      files_egl += files('drivers/dri2/platform_x11_dri3.c')
+      link_for_egl += libloader_dri3_helper
+    endif
+    deps_for_egl += [dep_x11_xcb, dep_xcb_dri2, dep_xcb_xfixes]
   endif
-  deps_for_egl += [dep_x11_xcb, dep_xcb_dri2, dep_xcb_xfixes]
-endif
-if with_platform_drm
-  files_egl += files('drivers/dri2/platform_drm.c')
-  link_for_egl += [libloader, libgbm, libxmlconfig]
-  incs_for_egl += [inc_loader, inc_gbm, include_directories('../gbm/main')]
-  deps_for_egl += dep_libdrm
-endif
-if with_platform_surfaceless
-  files_egl += files('drivers/dri2/platform_surfaceless.c')
-endif
-if with_platform_wayland
-  deps_for_egl += [dep_wayland_client, dep_wayland_server]
-  link_for_egl += libwayland_drm
-  files_egl += files('drivers/dri2/platform_wayland.c')
-  files_egl += [
-    linux_dmabuf_unstable_v1_protocol_c,
-    linux_dmabuf_unstable_v1_client_protocol_h,
-    wayland_drm_client_protocol_h,
-  ]
-  incs_for_egl += include_directories(
-    'wayland/wayland-egl', 'wayland/wayland-drm',
-  )
-endif
-if with_platform_android
-  deps_for_egl += dep_android
-  files_egl += files('drivers/dri2/platform_android.c')
-endif
-if with_platform_haiku
+  if with_platform_drm
+    files_egl += files('drivers/dri2/platform_drm.c')
+    link_for_egl += libgbm
+    incs_for_egl += [inc_gbm, include_directories('../gbm/main')]
+    deps_for_egl += dep_libdrm
+  endif
+  if with_platform_surfaceless
+    files_egl += files('drivers/dri2/platform_surfaceless.c')
+  endif
+  if with_platform_wayland
+    deps_for_egl += [dep_wayland_client, dep_wayland_server, dep_wayland_egl_headers]
+    link_for_egl += libwayland_drm
+    files_egl += files('drivers/dri2/platform_wayland.c')
+    files_egl += [
+      linux_dmabuf_unstable_v1_protocol_c,
+      linux_dmabuf_unstable_v1_client_protocol_h,
+      wayland_drm_client_protocol_h,
+    ]
+    incs_for_egl += include_directories('wayland/wayland-drm')
+  endif
+  if with_platform_android
+    deps_for_egl += dep_android
+    files_egl += files('drivers/dri2/platform_android.c')
+  endif
+elif with_platform_haiku
   incs_for_egl += inc_haikugl
   c_args_for_egl += [
     '-D_EGL_BUILT_IN_DRIVER_HAIKU',
@@ -141,14 +138,12 @@ if with_platform_haiku
   deps_for_egl += cpp.find_library('be')
 endif
 
-# TODO: glvnd
-
 if cc.has_function('mincore')
   c_args_for_egl += '-DHAVE_MINCORE'
 endif
 
 if not with_glvnd
-  egl_lib_name = 'EGL'
+  egl_lib_name = 'EGL' + get_option('egl-lib-suffix')
   egl_lib_version = '1.0.0'
 else
   egl_lib_name = 'EGL_mesa'
@@ -170,7 +165,7 @@ libegl = shared_library(
     '-D_EGL_NATIVE_PLATFORM=_EGL_PLATFORM_@0@'.format(egl_native_platform.to_upper()),
   ],
   include_directories : incs_for_egl,
-  link_with : [link_for_egl, libloader, libxmlconfig, libglapi, libmesa_util],
+  link_with : [link_for_egl, libglapi, libmesa_util],
   link_args : [ld_args_bsymbolic, ld_args_gc_sections],
   dependencies : [deps_for_egl, dep_dl, dep_libdrm, dep_clock, dep_thread],
   install : true,
@@ -197,22 +192,24 @@ pkg.generate(
   extra_cflags : gl_pkgconfig_c_flags,
 )
 
-if with_platform_wayland
-  subdir('wayland/wayland-egl')
-endif
-
-if with_tests
+if with_tests and prog_nm.found()
   if with_glvnd
     # TODO: add glvnd symbol check
   else
-    test('egl-symbols-check',
-      find_program('egl-symbols-check'),
-      env : env_test,
-      args : libegl
-    )
+    egl_symbols = files('egl-symbols.txt')
   endif
+  test('egl-symbols-check',
+    symbols_check,
+    args : [
+      '--lib', libegl,
+      '--symbols-file', egl_symbols,
+      '--nm', prog_nm.path(),
+    ],
+    suite : ['egl'],
+  )
   test('egl-entrypoint-check',
-    find_program('egl-entrypoint-check'),
-    env : [ 'srcdir=' + meson.current_source_dir() ]
+    prog_python,
+    args : files('egl-entrypoint-check.py', 'main/eglentrypoint.h'),
+    suite : ['egl'],
   )
 endif