egl: automatically compile the `drm` platform when available
[mesa.git] / src / egl / meson.build
index 7d738e2ebd11fb4e086c1a876d211652cb68b5de..29d22b1cb20597869811cb1e00ec0cc9072fc52e 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright Â© 2017 Intel Corporation
+# Copyright © 2017-2019 Intel Corporation
 
 # Permission is hereby granted, free of charge, to any person obtaining a copy
 # of this software and associated documentation files (the "Software"), to deal
@@ -96,7 +96,10 @@ if with_dri2
   link_for_egl += libloader
   incs_for_egl += inc_loader
 
-  files_egl += files('drivers/dri2/platform_device.c')
+  files_egl += files(
+    'drivers/dri2/platform_device.c',
+    'drivers/dri2/platform_surfaceless.c',
+  )
   if with_platform_x11
     files_egl += files('drivers/dri2/platform_x11.c')
     if with_dri3
@@ -105,15 +108,12 @@ if with_dri2
     endif
     deps_for_egl += [dep_x11_xcb, dep_xcb_dri2, dep_xcb_xfixes]
   endif
-  if with_platform_drm
+  if with_gbm
     files_egl += files('drivers/dri2/platform_drm.c')
     link_for_egl += libgbm
     incs_for_egl += [inc_gbm, include_directories('../gbm/main')]
     deps_for_egl += dep_libdrm
   endif
-  if with_platform_surfaceless
-    files_egl += files('drivers/dri2/platform_surfaceless.c')
-  endif
   if with_platform_wayland
     deps_for_egl += [dep_wayland_client, dep_wayland_server, dep_wayland_egl_headers]
     link_for_egl += libwayland_drm
@@ -149,6 +149,7 @@ if not with_glvnd
 else
   egl_lib_name = 'EGL_mesa'
   egl_lib_version = '0.0.0'
+  deps_for_egl += dep_glvnd
   files_egl += [g_egldispatchstubs_h, g_egldispatchstubs_c]
   files_egl += files('main/eglglvnd.c', 'main/egldispatchstubs.c')
   install_data(
@@ -161,10 +162,10 @@ libegl = shared_library(
   egl_lib_name,
   files_egl,
   c_args : [
-    c_vis_args,
     c_args_for_egl,
     '-D_EGL_NATIVE_PLATFORM=_EGL_PLATFORM_@0@'.format(egl_native_platform.to_upper()),
   ],
+  gnu_symbol_visibility : 'hidden',
   include_directories : incs_for_egl,
   link_with : [link_for_egl, libglapi],
   link_args : [ld_args_bsymbolic, ld_args_gc_sections],
@@ -173,28 +174,19 @@ libegl = shared_library(
   version : egl_lib_version,
 )
 
-# If using glvnd the pkg-config header should not point to EGL_mesa, it should
-# point to EGL. glvnd is only available on unix like platforms so adding -l
-# should be safe here
-if not with_glvnd or glvnd_missing_pc_files
-  if glvnd_missing_pc_files
-    _egl = '-L${libdir} -lEGL'
-  else
-    _egl = libegl
-  endif
-
+if not with_glvnd
   pkg.generate(
     name : 'egl',
     description : 'Mesa EGL Library',
     version : meson.project_version(),
-    libraries : _egl,
+    libraries : libegl,
     libraries_private: gl_priv_libs,
     requires_private : gl_priv_reqs,
     extra_cflags : gl_pkgconfig_c_flags,
   )
 endif
 
-if with_tests and prog_nm.found()
+if with_symbols_check
   if with_glvnd
     egl_symbols = files('egl-glvnd-symbols.txt')
   else
@@ -205,7 +197,7 @@ if with_tests and prog_nm.found()
     args : [
       '--lib', libegl,
       '--symbols-file', egl_symbols,
-      '--nm', prog_nm.path(),
+      symbols_check_args,
     ],
     suite : ['egl'],
   )