meson: Remove various completed todos
[mesa.git] / src / egl / meson.build
index 6537e4bdee61a49e5ae855c18584d472567553ee..5f30bbba89a2f98fbe78b01cbf171568147b3f0c 100644 (file)
@@ -102,6 +102,7 @@ if with_platform_x11
   if with_dri3
     files_egl += files('drivers/dri2/platform_x11_dri3.c')
     link_for_egl += libloader_dri3_helper
+    incs_for_egl += inc_loader
   endif
   deps_for_egl += [dep_x11_xcb, dep_xcb_dri2, dep_xcb_xfixes]
 endif
@@ -115,7 +116,7 @@ if with_platform_surfaceless
   files_egl += files('drivers/dri2/platform_surfaceless.c')
 endif
 if with_platform_wayland
-  deps_for_egl += [dep_wayland_client, dep_wayland_server]
+  deps_for_egl += [dep_wayland_client, dep_wayland_server, dep_wayland_egl_headers]
   link_for_egl += libwayland_drm
   files_egl += files('drivers/dri2/platform_wayland.c')
   files_egl += [
@@ -123,9 +124,7 @@ if with_platform_wayland
     linux_dmabuf_unstable_v1_client_protocol_h,
     wayland_drm_client_protocol_h,
   ]
-  incs_for_egl += include_directories(
-    'wayland/wayland-egl', 'wayland/wayland-drm',
-  )
+  incs_for_egl += include_directories('wayland/wayland-drm')
 endif
 if with_platform_android
   deps_for_egl += dep_android
@@ -141,8 +140,6 @@ if with_platform_haiku
   deps_for_egl += cpp.find_library('be')
 endif
 
-# TODO: glvnd
-
 if cc.has_function('mincore')
   c_args_for_egl += '-DHAVE_MINCORE'
 endif
@@ -197,10 +194,6 @@ pkg.generate(
   extra_cflags : gl_pkgconfig_c_flags,
 )
 
-if with_platform_wayland
-  subdir('wayland/wayland-egl')
-endif
-
 if with_tests
   if with_glvnd
     # TODO: add glvnd symbol check