meson: egl: group dri2 bits separately from haiku
[mesa.git] / src / egl / meson.build
index cf9320aecb246488f75a3d159ce96f937bd81777..8c0ffea8b40a1860cc880e59b185a0160887b3ef 100644 (file)
 # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
 # SOFTWARE.
 
+inc_egl = include_directories('.', 'main')
+inc_egl_dri2 = include_directories('drivers/dri2')
+
 c_args_for_egl = []
 link_for_egl = []
 deps_for_egl = []
-incs_for_egl = [inc_include, inc_src, include_directories('main')]
+incs_for_egl = [inc_include, inc_drm_uapi, inc_src, inc_egl]
 
 files_egl = files(
   'main/eglapi.c',
@@ -35,6 +38,8 @@ files_egl = files(
   'main/eglcurrent.c',
   'main/eglcurrent.h',
   'main/egldefines.h',
+  'main/egldevice.c',
+  'main/egldevice.h',
   'main/egldisplay.c',
   'main/egldisplay.h',
   'main/egldriver.c',
@@ -62,7 +67,7 @@ g_egldispatchstubs_c = custom_target(
   ],
   output : 'g_egldispatchstubs.c',
   command : [
-    prog_python2, '@INPUT0@', 'source', '@INPUT1@', '@INPUT2@', '@INPUT3@'
+    prog_python, '@INPUT0@', 'source', '@INPUT1@', '@INPUT2@', '@INPUT3@'
   ],
   depend_files : files('generate/genCommon.py'),
   capture : true,
@@ -76,7 +81,7 @@ g_egldispatchstubs_h = custom_target(
   ],
   output : 'g_egldispatchstubs.h',
   command : [
-    prog_python2, '@INPUT0@', 'header', '@INPUT1@', '@INPUT2@', '@INPUT3@'
+    prog_python, '@INPUT0@', 'header', '@INPUT1@', '@INPUT2@', '@INPUT3@'
   ],
   depend_files : files('generate/genCommon.py'),
   capture : true,
@@ -90,45 +95,44 @@ if with_dri2
   )
   c_args_for_egl += [
     '-DDEFAULT_DRIVER_DIR="@0@"'.format(dri_search_path),
-    '-D_EGL_BUILT_IN_DRIVER_DRI2',
   ]
-endif
 
-if with_platform_x11
-  files_egl += files('drivers/dri2/platform_x11.c')
-  if with_dri3
-    files_egl += files('drivers/dri2/platform_x11_dri3.c')
-    link_for_egl += libloader_dri3_helper
+  if with_platform_x11
+    files_egl += files('drivers/dri2/platform_x11.c')
+    incs_for_egl += inc_loader
+    if with_dri3
+      files_egl += files('drivers/dri2/platform_x11_dri3.c')
+      link_for_egl += libloader_dri3_helper
+    endif
+    deps_for_egl += [dep_x11_xcb, dep_xcb_dri2, dep_xcb_xfixes]
   endif
-  deps_for_egl += [dep_x11_xcb, dep_xcb_dri2, dep_xcb_xfixes]
-endif
-if with_platform_drm
-  files_egl += files('drivers/dri2/platform_drm.c')
-  link_for_egl += [libloader, libgbm, libxmlconfig]
-  incs_for_egl += [inc_loader, inc_gbm, include_directories('../gbm/main')]
-  deps_for_egl += dep_libdrm
-endif
-if with_platform_surfaceless
-  files_egl += files('drivers/dri2/platform_surfaceless.c')
-endif
-if with_platform_wayland
-  deps_for_egl += [dep_wayland_client, dep_wayland_server]
-  link_for_egl += libwayland_drm
-  files_egl += files('drivers/dri2/platform_wayland.c')
-  files_egl += [
-    linux_dmabuf_unstable_v1_protocol_c,
-    linux_dmabuf_unstable_v1_client_protocol_h,
-    wayland_drm_client_protocol_h,
-  ]
-  incs_for_egl += include_directories(
-    'wayland/wayland-egl', 'wayland/wayland-drm',
-  )
-endif
-if with_platform_android
-  deps_for_egl += dep_android
-  files_egl += files('drivers/dri2/platform_android.c')
-endif
-if with_platform_haiku
+  if with_platform_drm
+    files_egl += files('drivers/dri2/platform_drm.c')
+    link_for_egl += [libloader, libgbm, libxmlconfig]
+    incs_for_egl += [inc_loader, inc_gbm, include_directories('../gbm/main')]
+    deps_for_egl += dep_libdrm
+  endif
+  if with_platform_surfaceless
+    files_egl += files('drivers/dri2/platform_surfaceless.c')
+    incs_for_egl += [inc_loader]
+  endif
+  if with_platform_wayland
+    deps_for_egl += [dep_wayland_client, dep_wayland_server, dep_wayland_egl_headers]
+    link_for_egl += libwayland_drm
+    files_egl += files('drivers/dri2/platform_wayland.c')
+    files_egl += [
+      linux_dmabuf_unstable_v1_protocol_c,
+      linux_dmabuf_unstable_v1_client_protocol_h,
+      wayland_drm_client_protocol_h,
+    ]
+    incs_for_egl += include_directories('wayland/wayland-drm')
+  endif
+  if with_platform_android
+    deps_for_egl += dep_android
+    files_egl += files('drivers/dri2/platform_android.c')
+    incs_for_egl += [inc_loader]
+  endif
+elif with_platform_haiku
   incs_for_egl += inc_haikugl
   c_args_for_egl += [
     '-D_EGL_BUILT_IN_DRIVER_HAIKU',
@@ -138,8 +142,6 @@ if with_platform_haiku
   deps_for_egl += cpp.find_library('be')
 endif
 
-# TODO: glvnd
-
 if cc.has_function('mincore')
   c_args_for_egl += '-DHAVE_MINCORE'
 endif
@@ -174,26 +176,33 @@ libegl = shared_library(
   version : egl_lib_version,
 )
 
+# If using glvnd the pkg-config header should not point to EGL_mesa, it should
+# point to EGL. glvnd is only available on unix like platforms so adding -l
+# should be safe here
+# TODO: in the glvnd case glvnd itself should really be providing this.
+if with_glvnd
+  _egl = '-L${libdir} -lEGL'
+else
+  _egl = libegl
+endif
+
 pkg.generate(
   name : 'egl',
   description : 'Mesa EGL Library',
   version : meson.project_version(),
-  libraries : libegl,
+  libraries : _egl,
   libraries_private: gl_priv_libs,
   requires_private : gl_priv_reqs,
   extra_cflags : gl_pkgconfig_c_flags,
 )
 
-if with_platform_wayland
-  subdir('wayland/wayland-egl')
-endif
-
 if with_tests
   if with_glvnd
     # TODO: add glvnd symbol check
   else
     test('egl-symbols-check',
       find_program('egl-symbols-check'),
+      env : env_test,
       args : libegl
     )
   endif