egl/dri2: try to bind old context if bindContext failed
[mesa.git] / src / egl / meson.build
index dc67b7b1536bbc46fbffa77576a0fe6db2b9d050..aca3de261f995e83fdd34c1a1dacaae4d5bba287 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright © 2017 Intel Corporation
+# Copyright © 2017-2019 Intel Corporation
 
 # Permission is hereby granted, free of charge, to any person obtaining a copy
 # of this software and associated documentation files (the "Software"), to deal
@@ -28,7 +28,6 @@ incs_for_egl = [inc_include, inc_src, inc_egl]
 
 files_egl = files(
   'main/eglapi.c',
-  'main/eglapi.h',
   'main/eglarray.c',
   'main/eglarray.h',
   'main/eglconfig.c',
@@ -38,11 +37,12 @@ files_egl = files(
   'main/eglcurrent.c',
   'main/eglcurrent.h',
   'main/egldefines.h',
+  'main/egldevice.c',
+  'main/egldevice.h',
   'main/egldisplay.c',
   'main/egldisplay.h',
   'main/egldriver.c',
   'main/egldriver.h',
-  'main/eglfallbacks.c',
   'main/eglglobals.c',
   'main/eglglobals.h',
   'main/eglimage.c',
@@ -60,28 +60,28 @@ files_egl = files(
 g_egldispatchstubs_c = custom_target(
   'g_egldispatchstubs.c',
   input : [
-    'generate/gen_egl_dispatch.py', 'generate/eglFunctionList.py',
+    'generate/gen_egl_dispatch.py',
     'generate/egl.xml', 'generate/egl_other.xml'
   ],
   output : 'g_egldispatchstubs.c',
   command : [
-    prog_python2, '@INPUT0@', 'source', '@INPUT1@', '@INPUT2@', '@INPUT3@'
+    prog_python, '@INPUT0@', 'source', '@INPUT1@', '@INPUT2@',
   ],
-  depend_files : files('generate/genCommon.py'),
+  depend_files : [ files('generate/eglFunctionList.py'), genCommon_py, ],
   capture : true,
 )
 
 g_egldispatchstubs_h = custom_target(
   'g_egldispatchstubs.h',
   input : [
-    'generate/gen_egl_dispatch.py', 'generate/eglFunctionList.py',
+    'generate/gen_egl_dispatch.py',
     'generate/egl.xml', 'generate/egl_other.xml'
   ],
   output : 'g_egldispatchstubs.h',
   command : [
-    prog_python2, '@INPUT0@', 'header', '@INPUT1@', '@INPUT2@', '@INPUT3@'
+    prog_python, '@INPUT0@', 'header', '@INPUT1@', '@INPUT2@',
   ],
-  depend_files : files('generate/genCommon.py'),
+  depend_files : [ files('generate/eglFunctionList.py'), genCommon_py, ],
   capture : true,
 )
 
@@ -89,48 +89,45 @@ if with_dri2
   files_egl += files(
     'drivers/dri2/egl_dri2.c',
     'drivers/dri2/egl_dri2.h',
-    'drivers/dri2/egl_dri2_fallbacks.h',
   )
-  c_args_for_egl += [
-    '-DDEFAULT_DRIVER_DIR="@0@"'.format(dri_search_path),
-    '-D_EGL_BUILT_IN_DRIVER_DRI2',
-  ]
-endif
+  deps_for_egl += idep_xmlconfig
+  link_for_egl += libloader
+  incs_for_egl += inc_loader
 
-if with_platform_x11
-  files_egl += files('drivers/dri2/platform_x11.c')
-  if with_dri3
-    files_egl += files('drivers/dri2/platform_x11_dri3.c')
-    link_for_egl += libloader_dri3_helper
-    incs_for_egl += inc_loader
+  files_egl += files(
+    'drivers/dri2/platform_device.c',
+    'drivers/dri2/platform_surfaceless.c',
+  )
+  if with_platform_x11
+    files_egl += files('drivers/dri2/platform_x11.c')
+    if with_dri3
+      files_egl += files('drivers/dri2/platform_x11_dri3.c')
+      link_for_egl += libloader_dri3_helper
+    endif
+    deps_for_egl += [dep_x11_xcb, dep_xcb_dri2, dep_xcb_xfixes]
   endif
-  deps_for_egl += [dep_x11_xcb, dep_xcb_dri2, dep_xcb_xfixes]
-endif
-if with_platform_drm
-  files_egl += files('drivers/dri2/platform_drm.c')
-  link_for_egl += [libloader, libgbm, libxmlconfig]
-  incs_for_egl += [inc_loader, inc_gbm, include_directories('../gbm/main')]
-  deps_for_egl += dep_libdrm
-endif
-if with_platform_surfaceless
-  files_egl += files('drivers/dri2/platform_surfaceless.c')
-endif
-if with_platform_wayland
-  deps_for_egl += [dep_wayland_client, dep_wayland_server, dep_wayland_egl]
-  link_for_egl += libwayland_drm
-  files_egl += files('drivers/dri2/platform_wayland.c')
-  files_egl += [
-    linux_dmabuf_unstable_v1_protocol_c,
-    linux_dmabuf_unstable_v1_client_protocol_h,
-    wayland_drm_client_protocol_h,
-  ]
-  incs_for_egl += include_directories('wayland/wayland-drm')
-endif
-if with_platform_android
-  deps_for_egl += dep_android
-  files_egl += files('drivers/dri2/platform_android.c')
-endif
-if with_platform_haiku
+  if with_gbm
+    files_egl += files('drivers/dri2/platform_drm.c')
+    link_for_egl += libgbm
+    incs_for_egl += [inc_gbm, include_directories('../gbm/main')]
+    deps_for_egl += dep_libdrm
+  endif
+  if with_platform_wayland
+    deps_for_egl += [dep_wayland_client, dep_wayland_server, dep_wayland_egl_headers]
+    link_for_egl += libwayland_drm
+    files_egl += files('drivers/dri2/platform_wayland.c')
+    files_egl += [
+      linux_dmabuf_unstable_v1_protocol_c,
+      linux_dmabuf_unstable_v1_client_protocol_h,
+      wayland_drm_client_protocol_h,
+    ]
+    incs_for_egl += include_directories('wayland/wayland-drm')
+  endif
+  if with_platform_android
+    deps_for_egl += dep_android
+    files_egl += files('drivers/dri2/platform_android.c')
+  endif
+elif with_platform_haiku
   incs_for_egl += inc_haikugl
   c_args_for_egl += [
     '-D_EGL_BUILT_IN_DRIVER_HAIKU',
@@ -140,18 +137,17 @@ if with_platform_haiku
   deps_for_egl += cpp.find_library('be')
 endif
 
-# TODO: glvnd
-
 if cc.has_function('mincore')
   c_args_for_egl += '-DHAVE_MINCORE'
 endif
 
 if not with_glvnd
-  egl_lib_name = 'EGL'
+  egl_lib_name = 'EGL' + get_option('egl-lib-suffix')
   egl_lib_version = '1.0.0'
 else
   egl_lib_name = 'EGL_mesa'
   egl_lib_version = '0.0.0'
+  deps_for_egl += dep_glvnd
   files_egl += [g_egldispatchstubs_h, g_egldispatchstubs_c]
   files_egl += files('main/eglglvnd.c', 'main/egldispatchstubs.c')
   install_data(
@@ -164,50 +160,48 @@ libegl = shared_library(
   egl_lib_name,
   files_egl,
   c_args : [
-    c_vis_args,
     c_args_for_egl,
     '-D_EGL_NATIVE_PLATFORM=_EGL_PLATFORM_@0@'.format(egl_native_platform.to_upper()),
   ],
+  gnu_symbol_visibility : 'hidden',
   include_directories : incs_for_egl,
-  link_with : [link_for_egl, libloader, libxmlconfig, libglapi, libmesa_util],
+  link_with : [link_for_egl, libglapi],
   link_args : [ld_args_bsymbolic, ld_args_gc_sections],
-  dependencies : [deps_for_egl, dep_dl, dep_libdrm, dep_clock, dep_thread],
+  dependencies : [deps_for_egl, dep_dl, dep_libdrm, dep_clock, dep_thread, idep_mesautil],
   install : true,
   version : egl_lib_version,
 )
 
-# If using glvnd the pkg-config header should not point to EGL_mesa, it should
-# point to EGL. glvnd is only available on unix like platforms so adding -l
-# should be safe here
-# TODO: in the glvnd case glvnd itself should really be providing this.
-if with_glvnd
-  _egl = '-L${libdir} -lEGL'
-else
-  _egl = libegl
+if not with_glvnd
+  pkg.generate(
+    name : 'egl',
+    description : 'Mesa EGL Library',
+    version : meson.project_version(),
+    libraries : libegl,
+    libraries_private: gl_priv_libs,
+    requires_private : gl_priv_reqs,
+    extra_cflags : gl_pkgconfig_c_flags,
+  )
 endif
 
-pkg.generate(
-  name : 'egl',
-  description : 'Mesa EGL Library',
-  version : meson.project_version(),
-  libraries : _egl,
-  libraries_private: gl_priv_libs,
-  requires_private : gl_priv_reqs,
-  extra_cflags : gl_pkgconfig_c_flags,
-)
-
-if with_tests
+if with_symbols_check
   if with_glvnd
-    # TODO: add glvnd symbol check
+    egl_symbols = files('egl-glvnd-symbols.txt')
   else
-    test('egl-symbols-check',
-      find_program('egl-symbols-check'),
-      env : env_test,
-      args : libegl
-    )
+    egl_symbols = files('egl-symbols.txt')
   endif
+  test('egl-symbols-check',
+    symbols_check,
+    args : [
+      '--lib', libegl,
+      '--symbols-file', egl_symbols,
+      symbols_check_args,
+    ],
+    suite : ['egl'],
+  )
   test('egl-entrypoint-check',
-    find_program('egl-entrypoint-check'),
-    env : [ 'srcdir=' + meson.current_source_dir() ]
+    prog_python,
+    args : files('egl-entrypoint-check.py', 'main/eglentrypoint.h'),
+    suite : ['egl'],
   )
 endif