egl: add glvnd symbols check
[mesa.git] / src / egl / meson.build
index a6b66a06857d26742bfd9b9924202e03fe8ea18a..d864c099efa200e4c8c54497e42a8a549b47ee0a 100644 (file)
@@ -194,7 +194,7 @@ pkg.generate(
 
 if with_tests and prog_nm.found()
   if with_glvnd
 
 if with_tests and prog_nm.found()
   if with_glvnd
-    # TODO: add glvnd symbol check
+    egl_symbols = files('egl-glvnd-symbols.txt')
   else
     egl_symbols = files('egl-symbols.txt')
   endif
   else
     egl_symbols = files('egl-symbols.txt')
   endif
@@ -208,8 +208,8 @@ if with_tests and prog_nm.found()
     suite : ['egl'],
   )
   test('egl-entrypoint-check',
     suite : ['egl'],
   )
   test('egl-entrypoint-check',
-    find_program('egl-entrypoint-check'),
-    env : ['srcdir=' + meson.current_source_dir()],
+    prog_python,
+    args : files('egl-entrypoint-check.py', 'main/eglentrypoint.h'),
     suite : ['egl'],
   )
 endif
     suite : ['egl'],
   )
 endif