egl: drop unused _EGL_BUILT_IN_DRIVER_DRI2
[mesa.git] / src / egl / meson.build
index 9050d763a6cd9c4effe9e75b5511ff9113097892..e11e589b94561657746676ae645f3019e8a1efba 100644 (file)
@@ -24,7 +24,7 @@ inc_egl_dri2 = include_directories('drivers/dri2')
 c_args_for_egl = []
 link_for_egl = []
 deps_for_egl = []
-incs_for_egl = [inc_include, inc_src, inc_egl]
+incs_for_egl = [inc_include, inc_drm_uapi, inc_src, inc_egl]
 
 files_egl = files(
   'main/eglapi.c',
@@ -65,7 +65,7 @@ g_egldispatchstubs_c = custom_target(
   ],
   output : 'g_egldispatchstubs.c',
   command : [
-    prog_python2, '@INPUT0@', 'source', '@INPUT1@', '@INPUT2@', '@INPUT3@'
+    prog_python, '@INPUT0@', 'source', '@INPUT1@', '@INPUT2@', '@INPUT3@'
   ],
   depend_files : files('generate/genCommon.py'),
   capture : true,
@@ -79,7 +79,7 @@ g_egldispatchstubs_h = custom_target(
   ],
   output : 'g_egldispatchstubs.h',
   command : [
-    prog_python2, '@INPUT0@', 'header', '@INPUT1@', '@INPUT2@', '@INPUT3@'
+    prog_python, '@INPUT0@', 'header', '@INPUT1@', '@INPUT2@', '@INPUT3@'
   ],
   depend_files : files('generate/genCommon.py'),
   capture : true,
@@ -93,16 +93,15 @@ if with_dri2
   )
   c_args_for_egl += [
     '-DDEFAULT_DRIVER_DIR="@0@"'.format(dri_search_path),
-    '-D_EGL_BUILT_IN_DRIVER_DRI2',
   ]
 endif
 
 if with_platform_x11
   files_egl += files('drivers/dri2/platform_x11.c')
+  incs_for_egl += inc_loader
   if with_dri3
     files_egl += files('drivers/dri2/platform_x11_dri3.c')
     link_for_egl += libloader_dri3_helper
-    incs_for_egl += inc_loader
   endif
   deps_for_egl += [dep_x11_xcb, dep_xcb_dri2, dep_xcb_xfixes]
 endif
@@ -114,9 +113,10 @@ if with_platform_drm
 endif
 if with_platform_surfaceless
   files_egl += files('drivers/dri2/platform_surfaceless.c')
+  incs_for_egl += [inc_loader]
 endif
 if with_platform_wayland
-  deps_for_egl += [dep_wayland_client, dep_wayland_server]
+  deps_for_egl += [dep_wayland_client, dep_wayland_server, dep_wayland_egl_headers]
   link_for_egl += libwayland_drm
   files_egl += files('drivers/dri2/platform_wayland.c')
   files_egl += [
@@ -124,13 +124,12 @@ if with_platform_wayland
     linux_dmabuf_unstable_v1_client_protocol_h,
     wayland_drm_client_protocol_h,
   ]
-  incs_for_egl += include_directories(
-    'wayland/wayland-egl', 'wayland/wayland-drm',
-  )
+  incs_for_egl += include_directories('wayland/wayland-drm')
 endif
 if with_platform_android
   deps_for_egl += dep_android
   files_egl += files('drivers/dri2/platform_android.c')
+  incs_for_egl += [inc_loader]
 endif
 if with_platform_haiku
   incs_for_egl += inc_haikugl
@@ -142,8 +141,6 @@ if with_platform_haiku
   deps_for_egl += cpp.find_library('be')
 endif
 
-# TODO: glvnd
-
 if cc.has_function('mincore')
   c_args_for_egl += '-DHAVE_MINCORE'
 endif
@@ -198,10 +195,6 @@ pkg.generate(
   extra_cflags : gl_pkgconfig_c_flags,
 )
 
-if with_platform_wayland
-  subdir('wayland/wayland-egl')
-endif
-
 if with_tests
   if with_glvnd
     # TODO: add glvnd symbol check