meson: Move Wayland dmabuf to wayland-drm
[mesa.git] / src / egl / wayland / wayland-drm / meson.build
index fa334880530c6bd79299d6c304bfa8642bcaeb72..c627deaa1c34b8cbe323ae12d32f8cba3c594a9c 100644 (file)
@@ -48,3 +48,25 @@ libwayland_drm = static_library(
   dependencies : [dep_wayland_server],
   build_by_default : false,
 )
+
+# linux-dmabuf isn't part of wayland-drm, but this happens to be the only
+# place which is a) guaranteed to be built when building either or both
+# of EGL and Vulkan WSI, and b) guaranteed to be included before both,
+# so the targets are actually defined by the time the files come to be
+# used.
+#
+# Moving these to a src/wsi/ was suggested but shot down, so put these
+# here for now as the maybe-least-bad solution.
+linux_dmabuf_unstable_v1_protocol_c = custom_target(
+  'linux-dmabuf-unstable-v1-protocol.c',
+  input : wayland_dmabuf_xml,
+  output : 'linux-dmabuf-unstable-v1-protocol.c',
+  command : [prog_wl_scanner, 'code', '@INPUT@', '@OUTPUT@'],
+)
+
+linux_dmabuf_unstable_v1_client_protocol_h = custom_target(
+  'linux-dmabuf-unstable-v1-client-protocol.h',
+  input : wayland_dmabuf_xml,
+  output : 'linux-dmabuf-unstable-v1-client-protocol.h',
+  command : [prog_wl_scanner, 'client-header', '@INPUT@', '@OUTPUT@'],
+)