meson: build libEGL
[mesa.git] / src / egl / wayland / wayland-drm / meson.build
index 92adc29553170a7b376199d6ae1178c92b6f57a8..12b49ca4f06ccc0542d1dda8fd327b357095f729 100644 (file)
@@ -31,3 +31,17 @@ wayland_drm_client_protocol_h = custom_target(
   output : 'wayland-drm-client-protocol.h',
   command : [prog_wl_scanner, 'client-header', '@INPUT@', '@OUTPUT@'],
 )
+
+wayland_drm_server_protocol_h = custom_target(
+  'wayland-drm-server-protocol.h',
+  input : 'wayland-drm.xml',
+  output : 'wayland-drm-server-protocol.h',
+  command : [prog_wl_scanner, 'server-header', '@INPUT@', '@OUTPUT@'],
+)
+
+libwayland_drm = static_library(
+  'wayland_drm',
+  ['wayland-drm.c', wayland_drm_protocol_c, wayland_drm_server_protocol_h],
+  dependencies : [dep_wayland_server],
+  build_by_default : false,
+)