Added few more stubs so that control reaches to DestroyDevice().
[mesa.git] / src / egl / wayland / wayland-drm / meson.build
index c627deaa1c34b8cbe323ae12d32f8cba3c594a9c..b4782a013c9df7550bf8b51a1c81ef386a028699 100644 (file)
@@ -24,7 +24,7 @@ wayland_drm_protocol_c = custom_target(
   'wayland-drm-protocol.c',
   input : 'wayland-drm.xml',
   output : 'wayland-drm-protocol.c',
   'wayland-drm-protocol.c',
   input : 'wayland-drm.xml',
   output : 'wayland-drm-protocol.c',
-  command : [prog_wl_scanner, 'code', '@INPUT@', '@OUTPUT@'],
+  command : [prog_wl_scanner, wl_scanner_arg, '@INPUT@', '@OUTPUT@'],
 )
 
 wayland_drm_client_protocol_h = custom_target(
 )
 
 wayland_drm_client_protocol_h = custom_target(
@@ -44,7 +44,7 @@ wayland_drm_server_protocol_h = custom_target(
 libwayland_drm = static_library(
   'wayland_drm',
   ['wayland-drm.c', wayland_drm_protocol_c, wayland_drm_server_protocol_h],
 libwayland_drm = static_library(
   'wayland_drm',
   ['wayland-drm.c', wayland_drm_protocol_c, wayland_drm_server_protocol_h],
-  c_args : c_vis_args,
+  gnu_symbol_visibility : 'hidden',
   dependencies : [dep_wayland_server],
   build_by_default : false,
 )
   dependencies : [dep_wayland_server],
   build_by_default : false,
 )
@@ -61,7 +61,7 @@ linux_dmabuf_unstable_v1_protocol_c = custom_target(
   'linux-dmabuf-unstable-v1-protocol.c',
   input : wayland_dmabuf_xml,
   output : 'linux-dmabuf-unstable-v1-protocol.c',
   'linux-dmabuf-unstable-v1-protocol.c',
   input : wayland_dmabuf_xml,
   output : 'linux-dmabuf-unstable-v1-protocol.c',
-  command : [prog_wl_scanner, 'code', '@INPUT@', '@OUTPUT@'],
+  command : [prog_wl_scanner, wl_scanner_arg, '@INPUT@', '@OUTPUT@'],
 )
 
 linux_dmabuf_unstable_v1_client_protocol_h = custom_target(
 )
 
 linux_dmabuf_unstable_v1_client_protocol_h = custom_target(