freedreno/registers: install gzip'd register database
[mesa.git] / src / freedreno / decode / meson.build
index 74b3fd690d6e2c0b1532ad2af6aed25ba36b2ea3..9435fc8c04cf8a898766cd3f27adf377b87e4635 100644 (file)
@@ -36,11 +36,6 @@ libfreedreno_cffdec = static_library(
     'buffers.h',
     'cffdec.c',
     'cffdec.h',
-    'disasm-a2xx.c',
-    'disasm-a3xx.c',
-    'disasm.h',
-    'instr-a2xx.h',
-    'instr-a3xx.h',
     'pager.c',
     'pager.h',
     'rnnutil.c',
@@ -48,6 +43,7 @@ libfreedreno_cffdec = static_library(
     'util.h',
   ],
   include_directories: [
+    inc_freedreno,
     inc_freedreno_rnn,
     inc_include,
     inc_src,
@@ -55,7 +51,11 @@ libfreedreno_cffdec = static_library(
   c_args : [ no_override_init_args ],
   gnu_symbol_visibility: 'hidden',
   dependencies: [],
-  link_with: libfreedreno_rnn,
+  link_with: [
+    libfreedreno_rnn,
+    libfreedreno_ir2,  # for disasm_a2xx
+    libfreedreno_ir3,  # for disasm_a3xx
+  ],
   build_by_default: false,
 )
 
@@ -85,6 +85,7 @@ if dep_lua.found() and dep_libarchive.found()
       'script.h'
     ],
     include_directories: [
+      inc_freedreno,
       inc_freedreno_rnn,
       inc_include,
       inc_src,
@@ -99,7 +100,7 @@ if dep_lua.found() and dep_libarchive.found()
       libfreedreno_io,
     ],
     build_by_default: with_tools.contains('freedreno'),
-    install : with_tools.contains('freedreno'),
+    install: install_fd_decode_tools,
   )
 endif
 
@@ -107,6 +108,7 @@ crashdec = executable(
   'crashdec',
   'crashdec.c',
   include_directories: [
+    inc_freedreno,
     inc_freedreno_rnn,
     inc_include,
     inc_src,
@@ -117,7 +119,7 @@ crashdec = executable(
     libfreedreno_cffdec,
   ],
   build_by_default: with_tools.contains('freedreno'),
-  install : with_tools.contains('freedreno'),
+  install: install_fd_decode_tools,
 )
 
 if dep_libarchive.found()
@@ -125,6 +127,7 @@ if dep_libarchive.found()
     'pgmdump',
     'pgmdump.c',
     include_directories: [
+      inc_freedreno,
       inc_include,
       inc_src,
     ],
@@ -133,6 +136,8 @@ if dep_libarchive.found()
     link_with: [
       libfreedreno_cffdec,
       libfreedreno_io,
+      libfreedreno_ir2,  # for disasm_a2xx
+      libfreedreno_ir3,  # for disasm_a3xx
     ],
     build_by_default: with_tools.contains('freedreno'),
     install: false,
@@ -141,6 +146,7 @@ if dep_libarchive.found()
     'pgmdump2',
     'pgmdump2.c',
     include_directories: [
+      inc_freedreno,
       inc_include,
       inc_src,
     ],
@@ -149,6 +155,8 @@ if dep_libarchive.found()
     link_with: [
       libfreedreno_cffdec,
       libfreedreno_io,
+      libfreedreno_ir2,  # for disasm_a2xx
+      libfreedreno_ir3,  # for disasm_a3xx
     ],
     build_by_default: with_tools.contains('freedreno'),
     install: false,