freedreno: Add the outline of a test for a6xx texture layout.
[mesa.git] / src / freedreno / fdl / meson.build
index ded2164fc7e403aecf23fd59b20406329c38dcb9..0bbe1b257a51f2be789075e826950d48858ffcee 100644 (file)
@@ -31,3 +31,25 @@ libfreedreno_layout = static_library(
   build_by_default : false,
 )
 
+
+test(
+  'fd6_layout',
+  executable(
+    'fd6_layout',
+    [
+      'fd6_layout_test.c',
+      freedreno_xml_header_files,
+    ],
+    link_with: libfreedreno_layout,
+    dependencies : idep_mesautil,
+    include_directories: [
+      inc_include,
+      inc_src,
+      inc_mapi,
+      inc_mesa,
+      inc_gallium,
+      inc_gallium_aux,
+      inc_freedreno],
+  ),
+  suite : ['freedreno'],
+)