freedreno/registers: install gzip'd register database
[mesa.git] / src / freedreno / meson.build
index e039ab9c9a620981ec3b50fe6f72da51aaa8fe67..6ecf2e196aa7649d2911cc3db04922df27a69db7 100644 (file)
@@ -25,6 +25,12 @@ rnn_src_path = meson.source_root() + '/src/freedreno/registers'
 rnn_install_path = get_option('datadir') + '/freedreno/registers'
 rnn_path = rnn_src_path + ':' + get_option('prefix') + '/' + rnn_install_path
 
+dep_libxml2 = dependency('libxml-2.0', required: false)
+prog_gzip = find_program('gzip', required: false)
+
+install_fd_decode_tools = dep_libxml2.found() and prog_gzip.found() and \
+  with_tools.contains('freedreno')
+
 subdir('common')
 subdir('registers')
 subdir('drm')
@@ -34,8 +40,6 @@ subdir('fdl')
 subdir('perfcntrs')
 subdir('computerator')
 
-dep_libxml2 = dependency('libxml-2.0', required: false)
-
 # Everything that depends on rnn requires (indirectly) libxml2:
 if dep_libxml2.found()
   subdir('rnn')