util: promote u_memory to src/util
[mesa.git] / src / gallium / Makefile.am
index 26ed817bc288a262b65a8b783df8d5a362438d34..e75c1866832eedaade45752db72f64cb43d0f6af 100644 (file)
@@ -5,18 +5,12 @@ SUBDIRS =
 ##
 
 SUBDIRS += auxiliary
+SUBDIRS += auxiliary/pipe-loader
 
 ##
 ## Gallium pipe drivers and their respective winsys'
 ##
 
-SUBDIRS += \
-       drivers/galahad \
-       drivers/identity \
-       drivers/noop \
-       drivers/trace \
-       drivers/rbug
-
 ## freedreno/msm/kgsl
 if HAVE_GALLIUM_FREEDRENO
 SUBDIRS += drivers/freedreno winsys/freedreno/drm
@@ -27,11 +21,6 @@ if HAVE_GALLIUM_I915
 SUBDIRS += drivers/i915 winsys/i915/drm
 endif
 
-## ilo/i965
-if HAVE_GALLIUM_ILO
-SUBDIRS += drivers/ilo winsys/intel/drm
-endif
-
 ## nouveau
 if HAVE_GALLIUM_NOUVEAU
 SUBDIRS += drivers/nouveau winsys/nouveau/drm
@@ -47,11 +36,6 @@ if HAVE_GALLIUM_R300
 SUBDIRS += drivers/r300
 endif
 
-## radeon - linked into r600 and radeonsi
-if HAVE_GALLIUM_RADEON_COMMON
-SUBDIRS += drivers/radeon
-endif
-
 ## r600
 if HAVE_GALLIUM_R600
 SUBDIRS += drivers/r600
@@ -60,6 +44,7 @@ endif
 ## radeonsi
 if HAVE_GALLIUM_RADEONSI
 SUBDIRS += drivers/radeonsi
+SUBDIRS += winsys/amdgpu/drm
 endif
 
 ## the radeon winsys - linked in by r300, r600 and radeonsi
@@ -67,6 +52,18 @@ if NEED_RADEON_DRM_WINSYS
 SUBDIRS += winsys/radeon/drm
 endif
 
+if HAVE_GALLIUM_ETNAVIV
+SUBDIRS += drivers/etnaviv winsys/etnaviv/drm
+endif
+
+if HAVE_GALLIUM_IMX
+SUBDIRS += drivers/imx winsys/imx/drm
+endif
+
+if HAVE_GALLIUM_PL111
+SUBDIRS += drivers/pl111 winsys/pl111/drm
+endif
+
 ## swrast/softpipe
 if HAVE_GALLIUM_SOFTPIPE
 SUBDIRS += drivers/softpipe
@@ -77,11 +74,30 @@ SUBDIRS += drivers/llvmpipe
 endif
 endif
 
+if HAVE_GALLIUM_SWR
+SUBDIRS += drivers/swr
+endif
+
+## tegra
+if HAVE_GALLIUM_TEGRA
+SUBDIRS += drivers/tegra winsys/tegra/drm
+endif
+
 ## vc4/rpi
 if HAVE_GALLIUM_VC4
 SUBDIRS += drivers/vc4 winsys/vc4/drm
 endif
 
+## v3d
+if HAVE_GALLIUM_V3D
+SUBDIRS += drivers/v3d winsys/v3d/drm
+endif
+
+## virgl
+if HAVE_GALLIUM_VIRGL
+SUBDIRS += drivers/virgl winsys/virgl/drm winsys/virgl/vtest
+endif
+
 ## the sw winsys'
 SUBDIRS += winsys/sw/null
 
@@ -93,18 +109,10 @@ if HAVE_DRISW
 SUBDIRS += winsys/sw/dri
 endif
 
-if HAVE_DRI2
+if HAVE_DRISW_KMS
 SUBDIRS += winsys/sw/kms-dri
 endif
 
-if HAVE_EGL_PLATFORM_FBDEV
-SUBDIRS += winsys/sw/fbdev
-endif
-
-if HAVE_EGL_PLATFORM_WAYLAND
-SUBDIRS += winsys/sw/wayland
-endif
-
 SUBDIRS += winsys/sw/wrapper
 
 ##
@@ -112,7 +120,9 @@ SUBDIRS += winsys/sw/wrapper
 ##
 
 EXTRA_DIST = \
-       winsys/sw/android \
+       docs \
+       README.portability \
+       SConscript \
        winsys/sw/gdi \
        winsys/sw/hgl
 
@@ -121,7 +131,8 @@ EXTRA_DIST = \
 ## Gallium state trackers and their users (targets)
 ##
 
-if HAVE_LOADER_GALLIUM
+## XXX: Rename the conditional once we have a config switch for static/dynamic pipe-drivers
+if HAVE_CLOVER
 SUBDIRS += targets/pipe-loader
 endif
 
@@ -133,24 +144,15 @@ if HAVE_DRICOMMON
 SUBDIRS += state_trackers/dri targets/dri
 endif
 
-## the egl target depends on vega
-if HAVE_OPENVG
-SUBDIRS += state_trackers/vega
-endif
-
-if HAVE_GALLIUM_EGL
-SUBDIRS += state_trackers/egl targets/egl-static
-endif
-
-if HAVE_GALLIUM_GBM
-SUBDIRS += state_trackers/gbm targets/gbm
+if HAVE_GALLIUM_XLIB_GLX
+SUBDIRS += state_trackers/glx/xlib targets/libgl-xlib
 endif
 
-if HAVE_X11_DRIVER
-SUBDIRS += state_trackers/glx/xlib targets/libgl-xlib
+if HAVE_ST_OMX_BELLAGIO
+SUBDIRS += state_trackers/omx targets/omx
 endif
 
-if HAVE_ST_OMX
+if HAVE_ST_OMX_TIZONIA
 SUBDIRS += state_trackers/omx targets/omx
 endif
 
@@ -158,6 +160,10 @@ if HAVE_GALLIUM_OSMESA
 SUBDIRS += state_trackers/osmesa targets/osmesa
 endif
 
+if HAVE_ST_VA
+SUBDIRS += state_trackers/va targets/va
+endif
+
 if HAVE_ST_VDPAU
 SUBDIRS += state_trackers/vdpau targets/vdpau
 endif
@@ -170,11 +176,16 @@ if HAVE_ST_XVMC
 SUBDIRS += state_trackers/xvmc targets/xvmc
 endif
 
+if HAVE_ST_NINE
+SUBDIRS += state_trackers/nine targets/d3dadapter9
+endif
+
 ##
 ## Don't forget to bundle the remaining (non autotools) state-trackers/targets
 ##
 
 EXTRA_DIST += \
+       include \
        state_trackers/README \
        state_trackers/wgl targets/libgl-gdi \
        targets/graw-gdi targets/graw-null  targets/graw-xlib \
@@ -194,4 +205,7 @@ endif
 
 EXTRA_DIST += \
        tests/graw \
-       tests/python
+       tests/python \
+       meson.build \
+       tests/meson.build \
+       tests/graw/meson.build