util: promote u_memory to src/util
[mesa.git] / src / gallium / Makefile.am
index 9f98a7e28b6ea747db7521524e1dc03dddefd115..e75c1866832eedaade45752db72f64cb43d0f6af 100644 (file)
@@ -11,12 +11,6 @@ SUBDIRS += auxiliary/pipe-loader
 ## Gallium pipe drivers and their respective winsys'
 ##
 
-SUBDIRS += \
-       drivers/ddebug \
-       drivers/noop \
-       drivers/trace \
-       drivers/rbug
-
 ## freedreno/msm/kgsl
 if HAVE_GALLIUM_FREEDRENO
 SUBDIRS += drivers/freedreno winsys/freedreno/drm
@@ -42,11 +36,6 @@ if HAVE_GALLIUM_R300
 SUBDIRS += drivers/r300
 endif
 
-## radeon - linked into r600 and radeonsi
-if HAVE_GALLIUM_RADEON_COMMON
-SUBDIRS += drivers/radeon
-endif
-
 ## r600
 if HAVE_GALLIUM_R600
 SUBDIRS += drivers/r600
@@ -89,11 +78,21 @@ if HAVE_GALLIUM_SWR
 SUBDIRS += drivers/swr
 endif
 
+## tegra
+if HAVE_GALLIUM_TEGRA
+SUBDIRS += drivers/tegra winsys/tegra/drm
+endif
+
 ## vc4/rpi
 if HAVE_GALLIUM_VC4
 SUBDIRS += drivers/vc4 winsys/vc4/drm
 endif
 
+## v3d
+if HAVE_GALLIUM_V3D
+SUBDIRS += drivers/v3d winsys/v3d/drm
+endif
+
 ## virgl
 if HAVE_GALLIUM_VIRGL
 SUBDIRS += drivers/virgl winsys/virgl/drm winsys/virgl/vtest
@@ -149,7 +148,11 @@ if HAVE_GALLIUM_XLIB_GLX
 SUBDIRS += state_trackers/glx/xlib targets/libgl-xlib
 endif
 
-if HAVE_ST_OMX
+if HAVE_ST_OMX_BELLAGIO
+SUBDIRS += state_trackers/omx targets/omx
+endif
+
+if HAVE_ST_OMX_TIZONIA
 SUBDIRS += state_trackers/omx targets/omx
 endif
 
@@ -202,4 +205,7 @@ endif
 
 EXTRA_DIST += \
        tests/graw \
-       tests/python
+       tests/python \
+       meson.build \
+       tests/meson.build \
+       tests/graw/meson.build