util: promote u_memory to src/util
[mesa.git] / src / gallium / Makefile.am
index af010c89f8d9c513d03225395dc0ae88161c2b26..e75c1866832eedaade45752db72f64cb43d0f6af 100644 (file)
@@ -11,12 +11,6 @@ SUBDIRS += auxiliary/pipe-loader
 ## Gallium pipe drivers and their respective winsys'
 ##
 
-SUBDIRS += \
-       drivers/ddebug \
-       drivers/noop \
-       drivers/trace \
-       drivers/rbug
-
 ## freedreno/msm/kgsl
 if HAVE_GALLIUM_FREEDRENO
 SUBDIRS += drivers/freedreno winsys/freedreno/drm
@@ -42,11 +36,6 @@ if HAVE_GALLIUM_R300
 SUBDIRS += drivers/r300
 endif
 
-## radeon - linked into radeonsi
-if HAVE_GALLIUM_RADEON_COMMON
-SUBDIRS += drivers/radeon
-endif
-
 ## r600
 if HAVE_GALLIUM_R600
 SUBDIRS += drivers/r600
@@ -89,14 +78,19 @@ if HAVE_GALLIUM_SWR
 SUBDIRS += drivers/swr
 endif
 
+## tegra
+if HAVE_GALLIUM_TEGRA
+SUBDIRS += drivers/tegra winsys/tegra/drm
+endif
+
 ## vc4/rpi
 if HAVE_GALLIUM_VC4
 SUBDIRS += drivers/vc4 winsys/vc4/drm
 endif
 
-## vc5
-if HAVE_GALLIUM_VC5
-SUBDIRS += drivers/vc5 winsys/vc5/drm
+## v3d
+if HAVE_GALLIUM_V3D
+SUBDIRS += drivers/v3d winsys/v3d/drm
 endif
 
 ## virgl
@@ -155,7 +149,11 @@ SUBDIRS += state_trackers/glx/xlib targets/libgl-xlib
 endif
 
 if HAVE_ST_OMX_BELLAGIO
-SUBDIRS += state_trackers/omx_bellagio targets/omx-bellagio
+SUBDIRS += state_trackers/omx targets/omx
+endif
+
+if HAVE_ST_OMX_TIZONIA
+SUBDIRS += state_trackers/omx targets/omx
 endif
 
 if HAVE_GALLIUM_OSMESA
@@ -208,4 +206,6 @@ endif
 EXTRA_DIST += \
        tests/graw \
        tests/python \
-       meson.build
+       meson.build \
+       tests/meson.build \
+       tests/graw/meson.build