util: move u_cpu_detect to util
[mesa.git] / src / gallium / auxiliary / Makefile.am
index 07856e5a5289e00dd3d2fef080771f436bf18b21..4bfa7648389ced6bebb97048942127eea6a72bb6 100644 (file)
@@ -13,6 +13,7 @@ AM_CFLAGS = \
        $(MSVC2013_COMPAT_CFLAGS)
 
 AM_CXXFLAGS = \
+       $(GALLIUM_CFLAGS) \
        $(VISIBILITY_CXXFLAGS) \
        $(MSVC2013_COMPAT_CXXFLAGS)
 
@@ -21,6 +22,14 @@ libgallium_la_SOURCES = \
        $(NIR_SOURCES) \
        $(GENERATED_SOURCES)
 
+if HAVE_PLATFORM_ANDROID
+# Android's libbacktrace headers required C++11, but the Android toolchain (at
+# least in the Chrome OS SDK) does not enable C++11 by default.
+AM_CXXFLAGS += $(CXX11_CXXFLAGS)
+
+libgallium_la_SOURCES += util/u_debug_stack_android.cpp
+endif
+
 if HAVE_LIBDRM
 
 AM_CFLAGS += \
@@ -37,7 +46,6 @@ AM_CFLAGS += \
        $(LLVM_CFLAGS)
 
 AM_CXXFLAGS += \
-       $(GALLIUM_CFLAGS) \
        $(LLVM_CXXFLAGS)
 
 libgallium_la_SOURCES += \
@@ -118,6 +126,7 @@ EXTRA_DIST = \
        postprocess/ADDING \
        rbug/README \
        target-helpers \
+       util/u_debug_stack_android.cpp \
        util/u_format.csv \
        util/u_format_pack.py \
        util/u_format_parse.py \