util: Move u_debug to utils
[mesa.git] / src / gallium / auxiliary / meson.build
index bb7c0506d840bfe34a052921e5f3a45de395245a..1b5eb4d155d39030ba1bc43feeffae235ca558b2 100644 (file)
@@ -77,6 +77,35 @@ files_libgallium = files(
   'draw/draw_vs_exec.c',
   'draw/draw_vs.h',
   'draw/draw_vs_variant.c',
+  'driver_ddebug/dd_context.c',
+  'driver_ddebug/dd_draw.c',
+  'driver_ddebug/dd_pipe.h',
+  'driver_ddebug/dd_public.h',
+  'driver_ddebug/dd_screen.c',
+  'driver_ddebug/dd_util.h',
+  'driver_noop/noop_pipe.c',
+  'driver_noop/noop_public.h',
+  'driver_noop/noop_state.c',
+  'driver_rbug/rbug_context.c',
+  'driver_rbug/rbug_context.h',
+  'driver_rbug/rbug_core.c',
+  'driver_rbug/rbug_objects.c',
+  'driver_rbug/rbug_objects.h',
+  'driver_rbug/rbug_public.h',
+  'driver_rbug/rbug_screen.c',
+  'driver_rbug/rbug_screen.h',
+  'driver_trace/tr_context.c',
+  'driver_trace/tr_context.h',
+  'driver_trace/tr_dump.c',
+  'driver_trace/tr_dump_defines.h',
+  'driver_trace/tr_dump.h',
+  'driver_trace/tr_dump_state.c',
+  'driver_trace/tr_dump_state.h',
+  'driver_trace/tr_public.h',
+  'driver_trace/tr_screen.c',
+  'driver_trace/tr_screen.h',
+  'driver_trace/tr_texture.c',
+  'driver_trace/tr_texture.h',
   'hud/font.c',
   'hud/font.h',
   'hud/hud_context.c',
@@ -97,14 +126,10 @@ files_libgallium = files(
   'os/os_memory_debug.h',
   'os/os_memory_stdc.h',
   'os/os_memory.h',
-  'os/os_misc.c',
-  'os/os_misc.h',
   'os/os_mman.h',
   'os/os_process.c',
   'os/os_process.h',
   'os/os_thread.h',
-  'os/os_time.c',
-  'os/os_time.h',
   'pipebuffer/pb_buffer_fenced.c',
   'pipebuffer/pb_buffer_fenced.h',
   'pipebuffer/pb_buffer.h',
@@ -204,6 +229,8 @@ files_libgallium = files(
   'translate/translate_generic.c',
   'translate/translate_sse.c',
   'util/dbghelp.h',
+  'util/u_async_debug.h',
+  'util/u_async_debug.c',
   'util/u_bitcast.h',
   'util/u_bitmask.c',
   'util/u_bitmask.h',
@@ -217,8 +244,8 @@ files_libgallium = files(
   'util/u_cache.h',
   'util/u_cpu_detect.c',
   'util/u_cpu_detect.h',
-  'util/u_debug.c',
-  'util/u_debug.h',
+  'util/u_debug_gallium.h',
+  'util/u_debug_gallium.c',
   'util/u_debug_describe.c',
   'util/u_debug_describe.h',
   'util/u_debug_flush.c',
@@ -247,6 +274,8 @@ files_libgallium = files(
   'util/u_fifo.h',
   'util/u_format.c',
   'util/u_format.h',
+  'util/u_format_bptc.c',
+  'util/u_format_bptc.h',
   'util/u_format_etc.c',
   'util/u_format_etc.h',
   'util/u_format_latc.c',
@@ -283,8 +312,6 @@ files_libgallium = files(
   'util/u_linear.h',
   'util/u_log.c',
   'util/u_log.h',
-  'util/u_math.c',
-  'util/u_math.h',
   'util/u_memory.h',
   'util/u_mm.c',
   'util/u_mm.h',
@@ -293,6 +320,7 @@ files_libgallium = files(
   'util/u_pack_color.h',
   'util/u_pointer.h',
   'util/u_prim.h',
+  'util/u_prim.c',
   'util/u_prim_restart.c',
   'util/u_prim_restart.h',
   'util/u_pstipple.c',
@@ -306,6 +334,8 @@ files_libgallium = files(
   'util/u_ringbuffer.h',
   'util/u_sampler.c',
   'util/u_sampler.h',
+  'util/u_screen.c',
+  'util/u_screen.h',
   'util/u_simple_shaders.c',
   'util/u_simple_shaders.h',
   'util/u_split_prim.h',
@@ -322,9 +352,10 @@ files_libgallium = files(
   'util/u_texture.h',
   'util/u_tile.c',
   'util/u_tile.h',
-  'util/u_time.h',
   'util/u_transfer.c',
   'util/u_transfer.h',
+  'util/u_transfer_helper.c',
+  'util/u_transfer_helper.h',
   'util/u_threaded_context.c',
   'util/u_threaded_context.h',
   'util/u_threaded_context_calls.h',
@@ -338,7 +369,7 @@ files_libgallium = files(
   'nir/tgsi_to_nir.h',
 )
 
-if dep_libdrm != [] and dep_libdrm.found()
+if dep_libdrm.found()
   files_libgallium += files(
     'renderonly/renderonly.c',
     'renderonly/renderonly.h',
@@ -449,12 +480,18 @@ files_libgalliumvl = files(
   'vl/vl_vlc.h',
   'vl/vl_zscan.c',
   'vl/vl_zscan.h',
+  'vl/vl_probs_table.h',
 )
 
+vlwinsys_deps = []
 files_libgalliumvlwinsys = files('vl/vl_winsys.h')
-if with_dri2
+if with_dri2 and with_platform_x11
   files_libgalliumvlwinsys += files('vl/vl_winsys_dri.c')
   if with_dri3
+    vlwinsys_deps += [
+      dep_xcb_sync, dep_xcb_present, dep_xshmfence, dep_xcb_xfixes,
+      dep_xcb_dri3, 
+    ]
     files_libgalliumvlwinsys += files('vl/vl_winsys_dri3.c')
   endif
 endif
@@ -466,7 +503,7 @@ u_indices_gen_c = custom_target(
   'u_indices_gen.c',
   input : 'indices/u_indices_gen.py',
   output : 'u_indices_gen.c',
-  command : [prog_python2, '@INPUT@'],
+  command : [prog_python, '@INPUT@'],
   capture : true,
 )
 
@@ -474,7 +511,7 @@ u_unfilled_gen_c = custom_target(
   'u_unfilled_gen.c',
   input : 'indices/u_unfilled_gen.py',
   output : 'u_unfilled_gen.c',
-  command : [prog_python2, '@INPUT@'],
+  command : [prog_python, '@INPUT@'],
   capture : true,
 )
 
@@ -482,21 +519,23 @@ u_format_table_c = custom_target(
   'u_format_table.c',
   input : ['util/u_format_table.py', 'util/u_format.csv'],
   output : 'u_format_table.c',
-  command : [prog_python2, '@INPUT@'],
+  command : [prog_python, '@INPUT@'],
   depend_files : files('util/u_format_pack.py', 'util/u_format_parse.py'),
   capture : true,
 )
 
 libgallium = static_library(
   'gallium',
-  [files_libgallium, u_indices_gen_c, u_unfilled_gen_c, u_format_table_c,
-   nir_opcodes_h],
+  [files_libgallium, u_indices_gen_c, u_unfilled_gen_c, u_format_table_c],
   include_directories : [
     inc_loader, inc_gallium, inc_src, inc_include, include_directories('util')
   ],
   c_args : [c_vis_args, c_msvc_compat_args],
   cpp_args : [cpp_vis_args, cpp_msvc_compat_args],
-  dependencies : [dep_libdrm, dep_llvm, dep_unwind, dep_dl],
+  dependencies : [
+    dep_libdrm, dep_llvm, dep_unwind, dep_dl, dep_m, dep_thread, dep_lmsensors,
+    idep_nir_headers,
+  ],
   build_by_default : false,
 )
 
@@ -523,6 +562,6 @@ libgalliumvlwinsys = static_library(
   'galliumvlwinsys',
   files_libgalliumvlwinsys,
   include_directories : [inc_gallium, inc_include, inc_loader, inc_src],
-  dependencies : [dep_libdrm],
+  dependencies : [dep_libdrm, vlwinsys_deps],
   build_by_default : false,
 )