meson: fix pipe-loader compilation for windows
[mesa.git] / src / gallium / auxiliary / pipe-loader / meson.build
index 0e4b1ded5c5610a62b6158256d9ddd2c2332c410..d1888162a42d844c766c9c67859523e7714c4cb7 100644 (file)
@@ -27,9 +27,11 @@ files_pipe_loader = files(
 )
 
 libpipe_loader_defines = []
+libpipe_loader_links = []
 
 if dep_libdrm.found()
   files_pipe_loader += files('pipe_loader_drm.c')
+  libpipe_loader_links += libloader
 endif
 if with_dri
   libpipe_loader_defines += '-DHAVE_PIPE_LOADER_DRI'
@@ -37,6 +39,9 @@ endif
 if with_gallium_drisw_kms
   libpipe_loader_defines += '-DHAVE_PIPE_LOADER_KMS'
 endif
+if not (with_gallium_st_nine or with_gallium_opencl)
+  libpipe_loader_defines += '-DDROP_PIPE_LOADER_MISC'
+endif
 
 libpipe_loader_static = static_library(
   'pipe_loader_static',
@@ -64,7 +69,7 @@ libpipe_loader_dynamic = static_library(
       join_paths(get_option('prefix'), get_option('libdir'), 'gallium-pipe')
     )
   ],
-  link_with : libloader,
+  link_with : [libpipe_loader_links],
   dependencies : [dep_libdrm, idep_xmlconfig],
   build_by_default : false,
 )