lima/ppir: duplicate consts in nir
[mesa.git] / src / gallium / drivers / lima / meson.build
index 29c15bc2e1364dda1eeac6ea3163571d49d4890c..1b1affb0b24a985ceb5e26e04b560191d60a94ea 100644 (file)
@@ -31,6 +31,7 @@ files_lima = files(
   'ir/gp/reduce_scheduler.c',
   'ir/gp/regalloc.c',
   'ir/gp/disasm.c',
+  'ir/gp/optimize.c',
 
   'ir/pp/ppir.h',
   'ir/pp/nir.c',
@@ -45,7 +46,10 @@ files_lima = files(
   'ir/pp/node_to_instr.c',
   'ir/pp/disasm.c',
 
+  'ir/lima_nir_duplicate_consts.c',
+  'ir/lima_nir_duplicate_intrinsic.c',
   'ir/lima_nir_lower_uniform_to_scalar.c',
+  'ir/lima_nir_split_load_input.c',
 
   'ir/lima_ir.h',
 
@@ -61,8 +65,10 @@ files_lima = files(
   'lima_query.c',
   'lima_bo.c',
   'lima_bo.h',
-  'lima_submit.c',
-  'lima_submit.h',
+  'lima_job.c',
+  'lima_job.h',
+  'lima_parser.c',
+  'lima_parser.h',
   'lima_util.c',
   'lima_util.h',
   'lima_texture.c',
@@ -71,6 +77,7 @@ files_lima = files(
   'lima_fence.h',
   'lima_format.h',
   'lima_format.c',
+  'lima_gpu.h',
 )
 
 lima_nir_algebraic_c = custom_target(
@@ -125,3 +132,21 @@ lima_compiler = executable(
   install : with_tools.contains('lima'),
 )
 
+lima_disasm = executable(
+  'lima_disasm',
+  files(
+    'standalone/lima_disasm.c',
+  ),
+  include_directories : [
+    inc_src, inc_include, inc_gallium, inc_gallium_aux, inc_gallium_drivers, inc_mesa, inc_mapi, inc_compiler,
+  ],
+  dependencies : [
+    idep_mesautil,
+  ],
+  link_with : [
+    liblima,
+    libpanfrost_shared,
+  ],
+  build_by_default : with_tools.contains('lima'),
+  install : with_tools.contains('lima'),
+)