gitlab-ci: Add ppc64el and s390x cross-build jobs
[mesa.git] / src / gallium / drivers / llvmpipe / meson.build
index 7882beb358d5042630d4fee5111fcad891adaf77..570d1b221d8d3f20dec589032da2df3978ca6fc9 100644 (file)
@@ -101,7 +101,7 @@ libllvmpipe = static_library(
   c_args : [c_vis_args, c_msvc_compat_args],
   cpp_args : [cpp_vis_args, cpp_msvc_compat_args],
   include_directories : [inc_gallium, inc_gallium_aux, inc_include, inc_src],
   c_args : [c_vis_args, c_msvc_compat_args],
   cpp_args : [cpp_vis_args, cpp_msvc_compat_args],
   include_directories : [inc_gallium, inc_gallium_aux, inc_include, inc_src],
-  dependencies : dep_llvm,
+  dependencies : [ dep_llvm, idep_nir_headers, ],
 )
 
 # This overwrites the softpipe driver dependency, but itself depends on the
 )
 
 # This overwrites the softpipe driver dependency, but itself depends on the
@@ -125,6 +125,8 @@ if with_tests and with_gallium_softpipe and with_llvm
         link_with : [libllvmpipe, libgallium],
       ),
       suite : ['llvmpipe'],
         link_with : [libllvmpipe, libgallium],
       ),
       suite : ['llvmpipe'],
+      should_fail : meson.get_cross_property('xfail', '').contains(t),
+      timeout: 120,
     )
   endforeach
 endif
     )
   endforeach
 endif