gitlab-ci: Add ppc64el and s390x cross-build jobs
[mesa.git] / src / gallium / drivers / llvmpipe / meson.build
index 7eb752c8e9794edea05fe714311382aaf323c500..570d1b221d8d3f20dec589032da2df3978ca6fc9 100644 (file)
@@ -73,6 +73,8 @@ files_llvmpipe = files(
   'lp_state_blend.c',
   'lp_state_clip.c',
   'lp_state_derived.c',
+  'lp_state_cs.c',
+  'lp_state_cs.h',
   'lp_state_fs.c',
   'lp_state_fs.h',
   'lp_state_gs.c',
@@ -99,7 +101,7 @@ libllvmpipe = static_library(
   c_args : [c_vis_args, c_msvc_compat_args],
   cpp_args : [cpp_vis_args, cpp_msvc_compat_args],
   include_directories : [inc_gallium, inc_gallium_aux, inc_include, inc_src],
-  dependencies : dep_llvm,
+  dependencies : [ dep_llvm, idep_nir_headers, ],
 )
 
 # This overwrites the softpipe driver dependency, but itself depends on the
@@ -107,7 +109,7 @@ libllvmpipe = static_library(
 driver_swrast = declare_dependency(
   compile_args : '-DGALLIUM_LLVMPIPE',
   link_with : libllvmpipe,
-  dependencies : driver_swrast,
+  dependencies : [driver_swrast, dep_llvm],
 )
 
 if with_tests and with_gallium_softpipe and with_llvm
@@ -123,6 +125,8 @@ if with_tests and with_gallium_softpipe and with_llvm
         link_with : [libllvmpipe, libgallium],
       ),
       suite : ['llvmpipe'],
+      should_fail : meson.get_cross_property('xfail', '').contains(t),
+      timeout: 120,
     )
   endforeach
 endif