util: Move ralloc to a new src/util directory.
[mesa.git] / src / gallium / drivers / r300 / Makefile.am
index a8aaf221c9a8adeeb0375ddd19baff3f4ace094a..2c5951b8f6d20de4978bc96d3fbddfc160a7c070 100644 (file)
@@ -4,6 +4,7 @@ include Makefile.sources
 include $(top_srcdir)/src/gallium/Automake.inc
 
 AM_CFLAGS = \
+       -I$(top_srcdir)/src/util \
        -I$(top_srcdir)/src/mesa/program \
        -I$(top_srcdir)/src/mesa \
        -I$(top_srcdir)/src/glsl \
@@ -17,6 +18,7 @@ check_PROGRAMS = r300_compiler_tests
 TESTS = r300_compiler_tests
 
 r300_compiler_tests_LDADD = libr300.la libr300-helper.la \
+       $(top_builddir)/src/util/libmesautil.la \
        $(top_builddir)/src/gallium/auxiliary/libgallium.la \
        $(GALLIUM_COMMON_LIB_DEPS)
 r300_compiler_tests_CPPFLAGS = \
@@ -32,4 +34,5 @@ libr300_la_SOURCES = $(C_SOURCES)
 #
 # Solve this by building them into a separate helper library that can be linked
 # in place of libmesagallium.
+libr300_helper_la_CPPFLAGS = -I$(top_srcdir)/src
 libr300_helper_la_SOURCES = $(HELPER_SOURCES)