radeonsi: enable GL_EXT_shader_image_load_formatted
[mesa.git] / src / gallium / drivers / r600 / Makefile.am
index b2e37085f2339d460f1906ad482b5b0e0139ca22..c5b41cce26e493fa997becae073c6774da43276f 100644 (file)
@@ -1,15 +1,22 @@
-AUTOMAKE_OPTIONS = subdir-objects
-
 include Makefile.sources
 include $(top_srcdir)/src/gallium/Automake.inc
 
+egd_tables.h: $(srcdir)/egd_tables.py $(srcdir)/evergreend.h
+       $(AM_V_at)$(MKDIR_P) $(@D)
+       $(AM_V_GEN) $(PYTHON) $(srcdir)/egd_tables.py $(srcdir)/evergreend.h > $@
+
+BUILT_SOURCES = $(R600_GENERATED_FILES)
 AM_CFLAGS = \
        $(GALLIUM_DRIVER_CFLAGS) \
-       $(RADEON_CFLAGS)
+       $(RADEON_CFLAGS) \
+       $(LIBELF_CFLAGS) \
+       -I$(top_srcdir)/src/amd/common -Wstrict-overflow=0
 
 AM_CXXFLAGS = \
        $(GALLIUM_DRIVER_CXXFLAGS) \
-       $(RADEON_CFLAGS)
+       $(RADEON_CFLAGS) \
+       $(LIBELF_CFLAGS) \
+       -I$(top_srcdir)/src/amd/common
 
 noinst_LTLIBRARIES = libr600.la
 
@@ -17,27 +24,23 @@ libr600_la_SOURCES = \
        $(C_SOURCES) \
        $(CXX_SOURCES)
 
-libr600_la_LIBADD = ../radeon/libradeon.la
-
-if NEED_RADEON_LLVM
+if HAVE_GALLIUM_LLVM
 
 AM_CFLAGS += \
-       $(LLVM_CFLAGS) \
-       -I$(top_srcdir)/src/gallium/drivers/radeon/
-
-libr600_la_SOURCES += \
-       $(LLVM_C_SOURCES)
-
-libr600_la_LIBADD += ../radeon/libllvmradeon.la
+       $(LLVM_CFLAGS)
 
 endif
 
-if USE_R600_LLVM_COMPILER
-AM_CFLAGS += \
-       -DR600_USE_LLVM
-endif
-
 if HAVE_GALLIUM_COMPUTE
 AM_CFLAGS += \
        -DHAVE_OPENCL
 endif
+
+CLEANFILES = \
+       egd_tables.h
+
+EXTRA_DIST = \
+       egd_tables.py \
+       sb/notes.markdown \
+       sb/sb_bc_fmt_def.inc \
+       meson.build