radeonsi: generate register and packet tables for an IB parser from sid.h
[mesa.git] / src / gallium / drivers / radeonsi / Makefile.am
index aa79c5e01efc6e09c514ea71812186faf0a06d10..ae5035a89372c698f96f0d76a1db91cb660066a9 100644 (file)
@@ -31,3 +31,12 @@ AM_CFLAGS = \
 noinst_LTLIBRARIES = libradeonsi.la
 
 libradeonsi_la_SOURCES = $(C_SOURCES)
+
+sid_tables.h: $(srcdir)/sid_tables.py $(srcdir)/sid.h
+       $(AM_V_GEN) $(PYTHON2) $(srcdir)/sid_tables.py $(srcdir)/sid.h > $@
+
+EXTRA_DIST = \
+       sid_tables.py
+
+BUILT_SOURCES =\
+       sid_tables.h