meson: Build with Python 3
[mesa.git] / src / gallium / drivers / swr / rasterizer / codegen / meson.build
index 841540e0f3079479722e89f9d1e80c5e96db80cd..28275176022277a48a6693420b45ebaeb29895f1 100644 (file)
@@ -22,7 +22,7 @@ gen_knobs_cpp = custom_target(
   'gen_knobs.cpp',
   input : ['gen_knobs.py'],
   output : 'gen_knobs.cpp',
-  command : [prog_python2, '@INPUT0@', '--output', '@OUTPUT@', '--gen_cpp'],
+  command : [prog_python, '@INPUT0@', '--output', '@OUTPUT@', '--gen_cpp'],
   depend_files : files(
     'knob_defs.py', 'gen_common.py',
     'templates/gen_knobs.cpp',
@@ -33,7 +33,7 @@ gen_knobs_h = custom_target(
   'gen_knobs.h',
   input : ['gen_knobs.py'],
   output : 'gen_knobs.h',
-  command : [prog_python2, '@INPUT0@', '--output', '@OUTPUT@', '--gen_h'],
+  command : [prog_python, '@INPUT0@', '--output', '@OUTPUT@', '--gen_h'],
   depend_files : files(
     'knob_defs.py', 'gen_common.py',
     'templates/gen_knobs.h',
@@ -53,7 +53,7 @@ foreach x : [[swr_context_files, 'gen_swr_context_llvm.h'],
     x[1],
     input : ['gen_llvm_types.py', x[0]],
     output : x[1],
-    command : [prog_python2, '@INPUT0@', '--input', '@INPUT1@', '--output', '@OUTPUT@'],
+    command : [prog_python, '@INPUT0@', '--input', '@INPUT1@', '--output', '@OUTPUT@'],
     depend_files : files(
       'templates/gen_llvm.hpp',
       'gen_common.py',
@@ -70,7 +70,7 @@ foreach x : [['gen_ar_event.hpp', '--gen_event_hpp'],
     input : ['gen_archrast.py', swr_event_proto_files, swr_event_pproto_files],
     output : x[0],
     command : [
-      prog_python2,
+      prog_python,
       '@INPUT0@',
       '--proto', '@INPUT1@',
       '--proto_private', '@INPUT2@',