meson: Add Haiku platform support v4
[mesa.git] / src / gallium / meson.build
index d05e67630c697a5192b02adecb08a766f764c1c9..320fc0176e9ab6f95322e049926ab21a3ee215a4 100644 (file)
@@ -40,6 +40,9 @@ else
   libswkmsdri = []
 endif
 subdir('winsys/sw/wrapper')
+if with_platform_haiku
+  subdir('winsys/sw/hgl')
+endif
 if with_gallium_swr
   if meson.version().version_compare('< 0.44.0')
     error('SWR requires meson 0.44.0 or greater.')
@@ -153,6 +156,9 @@ endif
 if with_gallium_st_nine
   subdir('state_trackers/nine')
 endif
+if with_platform_haiku
+  subdir('state_trackers/hgl')
+endif
 if with_gallium_opencl
   # TODO: this isn't really clover specific, but ATM clover is the only
   # consumer
@@ -192,6 +198,9 @@ endif
 if with_gallium_xa
   subdir('targets/xa')
 endif
+if with_platform_haiku
+  subdir('targets/haiku-softpipe')
+endif
 if with_gallium_st_nine
   subdir('targets/d3dadapter9')
 endif