radeonsi: enable GL_EXT_shader_image_load_formatted
[mesa.git] / src / gallium / targets / d3dadapter9 / Makefile.am
index 65069240d883c46cace53478c1502ab7b75f1c9e..69cebbcd16fa123194b7e542344963d5f270ef93 100644 (file)
@@ -27,25 +27,15 @@ AM_CFLAGS = \
        -I$(top_srcdir)/src/loader \
        -I$(top_srcdir)/src/mapi/ \
        -I$(top_srcdir)/src/mesa/ \
+       -I$(top_builddir)/src/util \
        -I$(top_srcdir)/src/mesa/drivers/dri/common/ \
-       -I$(top_builddir)/src/mesa/drivers/dri/common/ \
        -I$(top_srcdir)/src/gallium/winsys \
        -I$(top_srcdir)/src/gallium/state_trackers/nine \
        $(GALLIUM_TARGET_CFLAGS) \
        $(VISIBILITY_CFLAGS)
 
-if HAVE_GALLIUM_STATIC_TARGETS
-AM_CPPFLAGS = \
-       -DNINE_TARGET \
-       -DGALLIUM_STATIC_TARGETS=1
-
-else
-
 AM_CPPFLAGS = \
-       -DPIPE_SEARCH_DIR=\"$(libdir)/gallium-pipe\" \
-       $(GALLIUM_PIPE_LOADER_DEFINES)
-
-endif
+       $(DEFINES)
 
 ninedir = $(D3D_DRIVER_INSTALL_DIR)
 nine_LTLIBRARIES = d3dadapter9.la
@@ -54,6 +44,7 @@ pkgconfigdir = $(libdir)/pkgconfig
 pkgconfig_DATA = d3d.pc
 
 d3dadapter9_la_SOURCES = \
+       description.c \
        getproc.c \
        drm.c
 
@@ -62,7 +53,7 @@ d3dadapter9_la_LDFLAGS = \
        -shrext .so \
        -module \
        -no-undefined \
-       -version-number $(NINE_MAJOR):$(NINE_MINOR) \
+       -version-number $(NINE_MAJOR):$(NINE_MINOR):$(NINE_PATCH) \
        $(GC_SECTIONS) \
        $(LD_NO_UNDEFINED)
 
@@ -76,19 +67,18 @@ d3dadapter9_la_LIBADD = \
        $(top_builddir)/src/gallium/auxiliary/libgallium.la \
        $(top_builddir)/src/gallium/state_trackers/nine/libninetracker.la \
        $(top_builddir)/src/util/libmesautil.la \
-       $(top_builddir)/src/gallium/winsys/sw/wrapper/libwsw.la \
        $(EXPAT_LIBS) \
        $(GALLIUM_COMMON_LIB_DEPS)
 
+EXTRA_d3dadapter9_la_DEPENDENCIES = d3dadapter9.sym
+EXTRA_DIST = d3dadapter9.sym meson.build
 
 TARGET_DRIVERS =
 TARGET_CPPFLAGS =
-TARGET_LIB_DEPS = $(top_builddir)/src/loader/libloader.la
+TARGET_LIB_DEPS =
 
 include $(top_srcdir)/src/gallium/drivers/i915/Automake.inc
 
-include $(top_srcdir)/src/gallium/drivers/ilo/Automake.inc
-
 include $(top_srcdir)/src/gallium/drivers/nouveau/Automake.inc
 
 include $(top_srcdir)/src/gallium/drivers/r300/Automake.inc
@@ -97,29 +87,27 @@ include $(top_srcdir)/src/gallium/drivers/radeonsi/Automake.inc
 
 include $(top_srcdir)/src/gallium/drivers/svga/Automake.inc
 
-include $(top_srcdir)/src/gallium/drivers/freedreno/Automake.inc
-
-include $(top_srcdir)/src/gallium/drivers/vc4/Automake.inc
-
 include $(top_srcdir)/src/gallium/drivers/softpipe/Automake.inc
 include $(top_srcdir)/src/gallium/drivers/llvmpipe/Automake.inc
 
 if HAVE_GALLIUM_STATIC_TARGETS
 
 d3dadapter9_la_CPPFLAGS = $(AM_CPPFLAGS) $(TARGET_CPPFLAGS)
-d3dadapter9_la_LIBADD += $(TARGET_LIB_DEPS) \
+d3dadapter9_la_LIBADD += \
+       $(top_builddir)/src/gallium/auxiliary/pipe-loader/libpipe_loader_static.la \
+       $(GALLIUM_PIPE_LOADER_WINSYS_LIBS) \
+       $(TARGET_LIB_DEPS) \
+       $(TARGET_COMPILER_LIB_DEPS) \
        $(TARGET_RADEON_WINSYS) $(TARGET_RADEON_COMMON)
 
 else # HAVE_GALLIUM_STATIC_TARGETS
 
 d3dadapter9_la_LIBADD += \
-       $(top_builddir)/src/gallium/auxiliary/pipe-loader/libpipe_loader.la \
-       $(GALLIUM_PIPE_LOADER_WINSYS_LIBS) \
-       $(GALLIUM_PIPE_LOADER_LIBS)
+       $(top_builddir)/src/gallium/auxiliary/pipe-loader/libpipe_loader_dynamic.la
 
 endif # HAVE_GALLIUM_STATIC_TARGETS
 
-if HAVE_MESA_LLVM
+if HAVE_GALLIUM_LLVM
 nodist_EXTRA_d3dadapter9_la_SOURCES = dummy.cpp
 d3dadapter9_la_LDFLAGS += $(LLVM_LDFLAGS)
 d3dadapter9_la_LIBADD += $(LLVM_LIBS)