Meson: Remove lib prefix from graw and osmesa when building with Mingw.
[mesa.git] / src / gallium / targets / graw-gdi / meson.build
index c3d3a0aac8eb85086f7a35ad08e37aeb58cb4822..563801cddd81e41769972d373277cfd411e7930d 100644 (file)
@@ -32,6 +32,7 @@ libgraw_gdi = shared_library(
   dependencies : [
     dep_ws2_32, idep_mesautil, driver_swrast,
   ],
+  name_prefix : host_machine.system() == 'windows' ? '' : 'lib',  # otherwise mingw will create libgraw.dll
 )
 
 libgraw = libgraw_gdi