radeonsi: enable GL_EXT_shader_image_load_formatted
[mesa.git] / src / gallium / targets / pipe-loader / Makefile.am
index 5f1330ab6564e3f5dd9d884278a6580de6f4b92d..864ee8d50d367d1e6faef0c1ba0a39605339f2d1 100644 (file)
@@ -25,38 +25,50 @@ include $(top_srcdir)/src/gallium/Automake.inc
 AM_CPPFLAGS = \
        $(GALLIUM_CFLAGS) \
        -I$(top_srcdir)/include \
+       -I$(top_builddir)/src/gallium/drivers \
        -I$(top_srcdir)/src/gallium/drivers \
        -I$(top_srcdir)/src/gallium/winsys \
+       -I$(top_builddir)/src/util \
+       $(GALLIUM_PIPE_LOADER_DEFINES) \
        $(LIBDRM_CFLAGS) \
-       $(VISIBILITY_CFLAGS) \
-       -DGALLIUM_RBUG \
-       -DGALLIUM_TRACE \
-       -DGALLIUM_GALAHAD
+       $(VISIBILITY_CFLAGS)
 
 pipedir = $(libdir)/gallium-pipe
 pipe_LTLIBRARIES =
 
-PIPE_LIBS = \
+PIPE_LIBS =
+
+if NEED_GALLIUM_VL
+PIPE_LIBS += \
+       $(top_builddir)/src/gallium/auxiliary/libgalliumvl.la
+else
+PIPE_LIBS += \
+       $(top_builddir)/src/gallium/auxiliary/libgalliumvl_stub.la
+endif
+
+if NEED_GALLIUM_VL_WINSYS
+PIPE_LIBS+= \
+       $(top_builddir)/src/gallium/auxiliary/libgalliumvlwinsys.la
+endif
+
+PIPE_LIBS += \
        $(top_builddir)/src/gallium/auxiliary/libgallium.la \
-        $(top_builddir)/src/util/libmesautil.la \
-       $(top_builddir)/src/gallium/drivers/rbug/librbug.la \
-       $(top_builddir)/src/gallium/drivers/trace/libtrace.la \
-       $(top_builddir)/src/gallium/drivers/galahad/libgalahad.la \
+       $(top_builddir)/src/compiler/nir/libnir.la \
+       $(top_builddir)/src/util/libmesautil.la \
        $(GALLIUM_COMMON_LIB_DEPS)
 
 AM_LDFLAGS = \
        -module \
        -no-undefined \
        -avoid-version \
-       $(GC_SECTIONS) \
-       $(LD_NO_UNDEFINED)
+       $(GC_SECTIONS)
 
 if HAVE_LD_VERSION_SCRIPT
 AM_LDFLAGS += \
        -Wl,--version-script=$(top_srcdir)/src/gallium/targets/pipe-loader/pipe.sym
 endif
 
-if HAVE_MESA_LLVM
+if HAVE_GALLIUM_LLVM
 PIPE_LIBS += $(LLVM_LIBS)
 AM_LDFLAGS += $(LLVM_LDFLAGS)
 endif
@@ -71,7 +83,7 @@ pipe_i915_la_LIBADD = \
        $(top_builddir)/src/gallium/winsys/i915/drm/libi915drm.la \
        $(top_builddir)/src/gallium/drivers/i915/libi915.la \
        $(LIBDRM_LIBS) \
-       $(INTEL_LIBS)
+       $(I915_LIBS)
 
 endif
 
@@ -111,11 +123,10 @@ nodist_EXTRA_pipe_r600_la_SOURCES = dummy.cpp
 pipe_r600_la_LIBADD = \
        $(PIPE_LIBS) \
        $(top_builddir)/src/gallium/winsys/radeon/drm/libradeonwinsys.la \
-       $(top_builddir)/src/gallium/drivers/radeon/libradeon.la \
        $(top_builddir)/src/gallium/drivers/r600/libr600.la \
        $(LIBDRM_LIBS) \
-       $(RADEON_LIBS)
-
+       $(RADEON_LIBS) \
+       $(LIBELF_LIBS)
 endif
 
 if HAVE_GALLIUM_RADEONSI
@@ -126,10 +137,13 @@ nodist_EXTRA_pipe_radeonsi_la_SOURCES = dummy.cpp
 pipe_radeonsi_la_LIBADD = \
        $(PIPE_LIBS) \
        $(top_builddir)/src/gallium/winsys/radeon/drm/libradeonwinsys.la \
-       $(top_builddir)/src/gallium/drivers/radeon/libradeon.la \
+       $(top_builddir)/src/gallium/winsys/amdgpu/drm/libamdgpuwinsys.la \
        $(top_builddir)/src/gallium/drivers/radeonsi/libradeonsi.la \
+       $(top_builddir)/src/amd/common/libamd_common.la \
+       $(top_builddir)/src/util/libxmlconfig.la \
        $(LIBDRM_LIBS) \
-       $(RADEON_LIBS)
+       $(RADEON_LIBS) \
+       $(AMDGPU_LIBS)
 
 endif
 
@@ -142,6 +156,8 @@ pipe_msm_la_LIBADD = \
        $(PIPE_LIBS) \
        $(top_builddir)/src/gallium/winsys/freedreno/drm/libfreedrenodrm.la \
        $(top_builddir)/src/gallium/drivers/freedreno/libfreedreno.la \
+       $(top_builddir)/src/freedreno/libfreedreno_drm.la \
+       $(top_builddir)/src/freedreno/libfreedreno_ir3.la \
        $(LIBDRM_LIBS) \
        $(FREEDRENO_LIBS)
 
@@ -161,16 +177,18 @@ pipe_vmwgfx_la_LIBADD = \
 
 endif
 
-if HAVE_GALLIUM_SOFTPIPE
-AM_CPPFLAGS += -DGALLIUM_SOFTPIPE
-
+if HAVE_GALLIUM_SWRAST
 pipe_LTLIBRARIES += pipe_swrast.la
 pipe_swrast_la_SOURCES = pipe_swrast.c
 nodist_EXTRA_pipe_swrast_la_SOURCES = dummy.cpp
+pipe_swrast_la_LIBADD = $(PIPE_LIBS)
 
-pipe_swrast_la_LIBADD = \
-       $(PIPE_LIBS) \
+if HAVE_GALLIUM_SOFTPIPE
+AM_CPPFLAGS += -DGALLIUM_SOFTPIPE
+
+pipe_swrast_la_LIBADD += \
        $(top_builddir)/src/gallium/drivers/softpipe/libsoftpipe.la
+endif
 
 if HAVE_GALLIUM_LLVMPIPE
 AM_CPPFLAGS += -DGALLIUM_LLVMPIPE
@@ -178,4 +196,17 @@ AM_CPPFLAGS += -DGALLIUM_LLVMPIPE
 pipe_swrast_la_LIBADD += \
        $(top_builddir)/src/gallium/drivers/llvmpipe/libllvmpipe.la
 endif
+
+if HAVE_GALLIUM_SWR
+AM_CPPFLAGS += -DGALLIUM_SWR
+
+pipe_swrast_la_LIBADD += \
+       $(top_builddir)/src/gallium/drivers/swr/libmesaswr.la
+endif
+
+pipe_swrast_la_LIBADD += \
+       $(GALLIUM_PIPE_LOADER_WINSYS_LIBS)
+
 endif
+
+EXTRA_DIST = pipe.sym meson.build