meson: replace libmesa_util with idep_mesautil
[mesa.git] / src / gallium / targets / pipe-loader / meson.build
index e9454d5666ae86a6a8ec365798fb8f0afcf519b1..045eb4174a71a789b5f472f546cc1e66405d197d 100644 (file)
@@ -20,7 +20,7 @@
 
 pipe_loader_link_args = [ld_args_gc_sections]
 pipe_loader_link_deps = []
-pipe_loader_link_with = [libgallium, libnir, libmesa_util]
+pipe_loader_link_with = [libgallium, libnir]
 pipe_loader_comp_args = []
 pipe_loader_incs = [
   inc_include, inc_src, inc_util, inc_gallium, inc_gallium_drivers,
@@ -69,7 +69,7 @@ foreach x : pipe_loaders
       link_depends : pipe_loader_link_deps,
       include_directories : pipe_loader_incs,
       link_with : [pipe_loader_link_with, x[3]],
-      dependencies : [dep_thread, x[2]],
+      dependencies : [idep_mesautil, dep_thread, x[2]],
       name_prefix : '',
       install : true,
       install_dir : pipe_loader_install_dir,