ci: Run tests on i386 cross builds
[mesa.git] / src / gallium / tests / unit / meson.build
index afde9840c370d6ec4dba2cdf5797c229869e1053..976218f22b7f3787c46cf356a07d8acdc0e1b9c1 100644 (file)
@@ -31,6 +31,8 @@ foreach t : ['pipe_barrier_test', 'u_cache_test', 'u_half_test',
   )
   # u_cache_test is slow, and translate_test fails.
   if not ['u_cache_test', 'translate_test'].contains(t)
-    test(t, exe, suite: 'gallium')
+    test(t, exe, suite: 'gallium',
+         should_fail : meson.get_cross_property('xfail', '').contains(t),
+    )
   endif
 endforeach