meson: Don't confuse the install and search paths for dri drivers
[mesa.git] / src / gbm / meson.build
index 14b9e960360abd6d6983a0790204f33b5801378a..2f5d1c6ddd7cdd4f666fbd2041f1be9130507cf1 100644 (file)
@@ -38,7 +38,7 @@ incs_gbm = [
 if with_dri2
   files_gbm += files('backends/dri/gbm_dri.c', 'backends/dri/gbm_driint.h')
   deps_gbm += dep_libdrm # TODO: pthread-stubs
-  args_gbm += '-DDEFAULT_DRIVER_DIR="@0@"'.format(dri_driver_dir)
+  args_gbm += '-DDEFAULT_DRIVER_DIR="@0@"'.format(dri_search_path)
 endif
 if with_platform_wayland
   deps_gbm += dep_wayland_server