gbm/dri: Expose visuals table through gbm_dri_device
[mesa.git] / src / gbm / meson.build
index 4b550e06f2790ae9a13d39bf820bfde3a48f58a2..2f5d1c6ddd7cdd4f666fbd2041f1be9130507cf1 100644 (file)
@@ -38,7 +38,7 @@ incs_gbm = [
 if with_dri2
   files_gbm += files('backends/dri/gbm_dri.c', 'backends/dri/gbm_driint.h')
   deps_gbm += dep_libdrm # TODO: pthread-stubs
-  args_gbm += '-DDEFAULT_DRIVER_DIR="@0@"'.format(dri_driver_dir)
+  args_gbm += '-DDEFAULT_DRIVER_DIR="@0@"'.format(dri_search_path)
 endif
 if with_platform_wayland
   deps_gbm += dep_wayland_server
@@ -54,7 +54,7 @@ libgbm = shared_library(
   c_args : [c_vis_args, args_gbm],
   link_args : [ld_args_gc_sections],
   link_with : [libloader, libmesa_util, libxmlconfig],
-  dependencies : [deps_gbm, dep_dl],
+  dependencies : [deps_gbm, dep_dl, dep_thread],
   version : '1.0.0',
   install : true,
 )
@@ -71,7 +71,8 @@ pkg.generate(
 )
 
 if with_tests
-  test('gbm-symbols-check',
+  test(
+    'gbm-symbols-check',
     find_program('gbm-symbols-check'),
     args : libgbm
   )