gbm/dri: Expose visuals table through gbm_dri_device
[mesa.git] / src / gbm / meson.build
index 6e512996add1cfadd189c3f02dbaec5a8590ff7a..2f5d1c6ddd7cdd4f666fbd2041f1be9130507cf1 100644 (file)
@@ -38,7 +38,7 @@ incs_gbm = [
 if with_dri2
   files_gbm += files('backends/dri/gbm_dri.c', 'backends/dri/gbm_driint.h')
   deps_gbm += dep_libdrm # TODO: pthread-stubs
-  args_gbm += '-DDEFAULT_DRIVER_DIR="@0@"'.format(dri_driver_dir)
+  args_gbm += '-DDEFAULT_DRIVER_DIR="@0@"'.format(dri_search_path)
 endif
 if with_platform_wayland
   deps_gbm += dep_wayland_server
@@ -71,7 +71,8 @@ pkg.generate(
 )
 
 if with_tests
-  test('gbm-symbols-check',
+  test(
+    'gbm-symbols-check',
     find_program('gbm-symbols-check'),
     args : libgbm
   )