gbm: use new symbols check script
[mesa.git] / src / gbm / meson.build
index b2ad66735926fc33881375b16ebe3d594ee91f6c..39fa0386a657ae52c6edbd1fc697dc3dcfcf9c4f 100644 (file)
@@ -66,12 +66,15 @@ pkg.generate(
   libraries_private : '-ldl',  # FIXME: autotools lists this a incomplete
 )
 
-if with_tests
+if with_tests and prog_nm.found()
   test(
     'gbm-symbols-check',
-    find_program('gbm-symbols-check'),
-    env : env_test,
-    args : libgbm,
+    symbols_check,
+    args : [
+      '--lib', libgbm,
+      '--symbols-file', files('gbm-symbols.txt'),
+      '--nm', prog_nm.path(),
+    ],
     suite : ['gbm'],
   )
 endif