meson: move the generic symbols check arguments to a common variable
[mesa.git] / src / gbm / meson.build
index 39fa0386a657ae52c6edbd1fc697dc3dcfcf9c4f..ed4310d6598662804a79e6c847f8a67166e7c490 100644 (file)
@@ -49,8 +49,8 @@ libgbm = shared_library(
   include_directories : incs_gbm,
   c_args : [c_vis_args, args_gbm],
   link_args : [ld_args_gc_sections],
-  link_with : [libloader, libmesa_util, libxmlconfig],
-  dependencies : [deps_gbm, dep_dl, dep_thread],
+  link_with : libloader,
+  dependencies : [deps_gbm, dep_dl, dep_thread, idep_mesautil, idep_xmlconfig],
   version : '1.0.0',
   install : true,
 )
@@ -66,14 +66,14 @@ pkg.generate(
   libraries_private : '-ldl',  # FIXME: autotools lists this a incomplete
 )
 
-if with_tests and prog_nm.found()
+if with_symbols_check
   test(
     'gbm-symbols-check',
     symbols_check,
     args : [
       '--lib', libgbm,
       '--symbols-file', files('gbm-symbols.txt'),
-      '--nm', prog_nm.path(),
+      symbols_check_args,
     ],
     suite : ['gbm'],
   )