Merge branch 'master' of ../mesa into vulkan
[mesa.git] / src / glsl / Makefile.am
index 32653911f6c07e7003698bad77506f2201eeb77c..08368311b8a8535439533b1da465a0b846bac41e 100644 (file)
@@ -78,7 +78,7 @@ check_PROGRAMS =                                      \
        tests/sampler-types-test                        \
        tests/uniform-initializer-test
 
-noinst_PROGRAMS = glsl_compiler
+noinst_PROGRAMS = glsl_compiler spirv2nir
 
 tests_blob_test_SOURCES =                              \
        tests/blob_test.c
@@ -162,6 +162,16 @@ glsl_compiler_LDADD =                                      \
        $(top_builddir)/src/libglsl_util.la             \
        $(PTHREAD_LIBS)
 
+spirv2nir_SOURCES = \
+       standalone_scaffolding.cpp \
+       standalone_scaffolding.h \
+       nir/spirv2nir.c
+
+spirv2nir_LDADD =                                      \
+       libglsl.la                                      \
+       $(top_builddir)/src/libglsl_util.la             \
+       $(PTHREAD_LIBS)
+
 glsl_test_SOURCES = \
        standalone_scaffolding.cpp \
        test.cpp \