Merge remote-tracking branch 'mesa-public/master' into vulkan
[mesa.git] / src / glsl / Makefile.am
index fa8c9f5d3ca63404477678831e98c25e7d0213f6..74da9e5b979987efc852d9908986ca1c74c90a3d 100644 (file)
@@ -77,7 +77,7 @@ check_PROGRAMS =                                      \
        tests/sampler-types-test                        \
        tests/uniform-initializer-test
 
-noinst_PROGRAMS = glsl_compiler
+noinst_PROGRAMS = glsl_compiler spirv2nir
 
 tests_blob_test_SOURCES =                              \
        tests/blob_test.c
@@ -158,6 +158,16 @@ glsl_compiler_LDADD =                                      \
        $(top_builddir)/src/libglsl_util.la             \
        $(PTHREAD_LIBS)
 
+spirv2nir_SOURCES = \
+       standalone_scaffolding.cpp \
+       standalone_scaffolding.h \
+       nir/spirv2nir.c
+
+spirv2nir_LDADD =                                      \
+       libglsl.la                                      \
+       $(top_builddir)/src/libglsl_util.la             \
+       $(PTHREAD_LIBS)
+
 glsl_test_SOURCES = \
        standalone_scaffolding.cpp \
        test.cpp \