meson: move gl pkgconfig generation out of glx
[mesa.git] / src / glx / meson.build
index 70718df4d35fdb1a3f22fb538046e9f3b37abe52..43f8fb24efd0f866a0ee30fccb1b245f80cd47fa 100644 (file)
@@ -106,13 +106,13 @@ elif with_windowsdri
   #]
 endif
 
-dri_driver_dir = join_paths(get_option('prefix'), get_option('libdir'), 'dri')
+dri_driver_dir = join_paths(get_option('prefix'), dri_drivers_path)
 if not with_glvnd
   gl_lib_name = 'GL'
   gl_lib_version = '1.2.0'
 else
   gl_lib_name = 'GLX_mesa'
-  gl_lib_version = '0'
+  gl_lib_version = '0.0.0'
   files_libglx += files(
     'g_glxglvnddispatchfuncs.c',
     'g_glxglvnddispatchindices.h',
@@ -126,7 +126,7 @@ gl_lib_cargs = [
   '-D_REENTRANT', '-DDEFAULT_DRIVER_DIR="@0@"'.format(dri_driver_dir),
 ]
 
-if dep_xf86vm != [] and dep_xf86vm.found()
+if dep_xxf86vm != [] and dep_xxf86vm.found()
   gl_lib_cargs += '-DHAVE_XF86VIDMODE'
 endif
 
@@ -167,39 +167,6 @@ if with_glx == 'dri'
     version : gl_lib_version,
     install : true,
   )
-
-  gl_priv_reqs = [
-    'x11', 'xext', 'xdamage >= 1.1', 'xfixes', 'x11-xcb', 'xcb',
-    'xcb-glx >= 1.8.1', 'libdrm >= 2.4.75',
-  ]
-  if dep_xf86vm.found()
-    gl_priv_reqs += 'xf86vm'
-  endif
-  if with_dri_platform == 'drm'
-    gl_priv_reqs += 'xcb-dri2 >= 1.8'
-  endif
-
-  gl_priv_libs = []
-  if dep_thread.found()
-    gl_priv_libs += ['-lpthread', '-pthread']
-  endif
-  if dep_m.found()
-    gl_priv_libs += '-lm'
-  endif
-  if dep_dl.found()
-    gl_priv_libs += '-ldl'
-  endif
-
-  pkg.generate(
-    name : 'gl',
-    filebase : 'gl',
-    description : 'Mesa OpenGL Library',
-    version : meson.project_version(),
-    libraries : libgl,
-    libraries_private : gl_priv_libs,
-    requires_private : gl_priv_reqs,
-    variables : ['glx_tls=yes'],
-  )
 endif
 
 if with_tests